summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-19 09:55:12 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-19 09:55:12 +0000
commit0ca7cb837eb9e24c8dddb68f38610aa3ce885ddb (patch)
tree48967f2d8de74807a44dc6e37d4fb36e03d22757 /x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild
parentrewrite of all gtk theme engines for new eclass (diff)
downloadgentoo-2-0ca7cb837eb9e24c8dddb68f38610aa3ce885ddb.tar.gz
gentoo-2-0ca7cb837eb9e24c8dddb68f38610aa3ce885ddb.tar.bz2
gentoo-2-0ca7cb837eb9e24c8dddb68f38610aa3ce885ddb.zip
rewrite of all gtk theme engines for new eclass
Diffstat (limited to 'x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild')
-rw-r--r--x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild b/x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild
new file mode 100644
index 000000000000..ec5bc74b49cb
--- /dev/null
+++ b/x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xenophilia/gtk-engines-xenophilia-0.8-r1.ebuild,v 1.1 2003/06/19 09:52:07 liquidx Exp $
+
+inherit gtk-engines2
+
+IUSE=""
+DESCRIPTION="GTK+1 Xenophilia Theme Engine"
+HOMEPAGE="http://themes.freshmeat.net/projects/xenophilia/"
+SRC_URI="http://download.freshmeat.net/themes/xenophilia/xenophilia-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+SLOT="1"
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+S=${WORKDIR}/Xenophilia-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # disable fonts installation
+ sed -i -e "s/\(SUBDIR.*\)fonts\(.*\)/\1\2/" Makefile.in
+}
+
+src_install() {
+ einstall \
+ THEME_DIR=${D}/usr/share/themes \
+ ENGINE_DIR=${D}/usr/lib/gtk/themes/engines \
+ || die "Installation failed"
+
+ dodoc ${DEFAULT_DOCS}
+
+ # FIXME: install fonts
+}