summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-12-01 09:44:35 +0000
committerMart Raudsepp <leio@gentoo.org>2008-12-01 09:44:35 +0000
commitd1b16ce4848663b250e421a6a9ae57c1dc9c95c9 (patch)
treeb9ffad460eddfe272ff2f3d51732e13568679b50 /x11-terms
parentclean up (diff)
downloadgentoo-2-d1b16ce4848663b250e421a6a9ae57c1dc9c95c9.tar.gz
gentoo-2-d1b16ce4848663b250e421a6a9ae57c1dc9c95c9.tar.bz2
gentoo-2-d1b16ce4848663b250e421a6a9ae57c1dc9c95c9.zip
Version bump. Add patches to bring back "Switch to Tab <n>" functionality completely, including the keyboard shortcuts dialog entries and translations.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/ChangeLog11
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-2.24.2-restore-switch-to-tab.patch389
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.24.2.ebuild50
3 files changed, 449 insertions, 1 deletions
diff --git a/x11-terms/gnome-terminal/ChangeLog b/x11-terms/gnome-terminal/ChangeLog
index 2847fd5df7c2..e898497b77de 100644
--- a/x11-terms/gnome-terminal/ChangeLog
+++ b/x11-terms/gnome-terminal/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-terms/gnome-terminal
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.182 2008/11/13 19:11:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.183 2008/12/01 09:44:35 leio Exp $
+
+*gnome-terminal-2.24.2 (01 Dec 2008)
+
+ 01 Dec 2008; Mart Raudsepp <leio@gentoo.org>
+ +files/gnome-terminal-2.24.2-restore-switch-to-tab.patch,
+ +gnome-terminal-2.24.2.ebuild:
+ Version bump. Add patches to bring back "Switch to Tab <n>" functionality
+ completely, including the keyboard shortcuts dialog entries and
+ translations.
13 Nov 2008; Brent Baude <ranger@gentoo.org>
gnome-terminal-2.22.3-r1.ebuild:
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-2.24.2-restore-switch-to-tab.patch b/x11-terms/gnome-terminal/files/gnome-terminal-2.24.2-restore-switch-to-tab.patch
new file mode 100644
index 000000000000..04f067591c68
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-2.24.2-restore-switch-to-tab.patch
@@ -0,0 +1,389 @@
+Index: src/terminal-accels.c
+===================================================================
+--- src/terminal-accels.c (revision 3169)
++++ src/terminal-accels.c (revision 3171)
+@@ -20,11 +20,14 @@
+
+ #include <string.h>
+
++#include <gdk/gdkkeysyms.h>
++
+ #include "terminal-accels.h"
+ #include "terminal-app.h"
+ #include "terminal-intl.h"
+ #include "terminal-profile.h"
+ #include "terminal-util.h"
++#include "terminal-accels.h"
+
+ #ifdef DEBUG_ACCELS
+ #define D(x) x
+@@ -71,6 +74,7 @@
+ #define ACCEL_PATH_MOVE_TAB_LEFT ACCEL_PATH_ROOT "TabsMoveLeft"
+ #define ACCEL_PATH_MOVE_TAB_RIGHT ACCEL_PATH_ROOT "TabsMoveRight"
+ #define ACCEL_PATH_DETACH_TAB ACCEL_PATH_ROOT "TabsDetach"
++#define ACCEL_PATH_SWITCH_TAB_PREFIX ACCEL_PATH_ROOT "TabsSwitch"
+
+ #define KEY_CLOSE_TAB CONF_KEYS_PREFIX "/close_tab"
+ #define KEY_CLOSE_WINDOW CONF_KEYS_PREFIX "/close_window"
+@@ -93,6 +97,7 @@
+ #define KEY_ZOOM_IN CONF_KEYS_PREFIX "/zoom_in"
+ #define KEY_ZOOM_NORMAL CONF_KEYS_PREFIX "/zoom_normal"
+ #define KEY_ZOOM_OUT CONF_KEYS_PREFIX "/zoom_out"
++#define KEY_SWITCH_TAB_PREFIX CONF_KEYS_PREFIX "/switch_to_tab_"
+
+ typedef struct
+ {
+@@ -173,6 +178,42 @@
+ KEY_MOVE_TAB_RIGHT, ACCEL_PATH_MOVE_TAB_RIGHT, 0, 0, NULL, FALSE, TRUE },
+ { N_("Detach Tab"),
+ KEY_DETACH_TAB, ACCEL_PATH_DETACH_TAB, 0, 0, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 1"),
++ KEY_SWITCH_TAB_PREFIX "1",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "1", GDK_1, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 2"),
++ KEY_SWITCH_TAB_PREFIX "2",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "2", GDK_2, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 3"),
++ KEY_SWITCH_TAB_PREFIX "3",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "3", GDK_3, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 4"),
++ KEY_SWITCH_TAB_PREFIX "4",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "4", GDK_4, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 5"),
++ KEY_SWITCH_TAB_PREFIX "5",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "5", GDK_5, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 6"),
++ KEY_SWITCH_TAB_PREFIX "6",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "6", GDK_6, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 7"),
++ KEY_SWITCH_TAB_PREFIX "7",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "7", GDK_7, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 8"),
++ KEY_SWITCH_TAB_PREFIX "8",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "8", GDK_8, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 9"),
++ KEY_SWITCH_TAB_PREFIX "9",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "9", GDK_9, GDK_MOD1_MASK, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 10"),
++ KEY_SWITCH_TAB_PREFIX "10",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "10", 0, 0, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 11"),
++ KEY_SWITCH_TAB_PREFIX "11",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "11", 0, 0, NULL, FALSE, TRUE },
++ { N_("Switch to Tab 12"),
++ KEY_SWITCH_TAB_PREFIX "12",
++ ACCEL_PATH_SWITCH_TAB_PREFIX "12", 0, 0, NULL, FALSE, TRUE }
+ };
+
+ static KeyEntry help_entries[] = {
+@@ -186,7 +227,7 @@
+ { view_entries, G_N_ELEMENTS (view_entries), N_("View") },
+ { terminal_entries, G_N_ELEMENTS (terminal_entries), N_("Terminal") },
+ { tabs_entries, G_N_ELEMENTS (tabs_entries), N_("Tabs") },
+- { help_entries, G_N_ELEMENTS (help_entries), N_("Help") }
++ { help_entries, G_N_ELEMENTS (help_entries), N_("Help") },
+ };
+
+ enum
+Index: src/terminal-tabs-menu.c
+===================================================================
+--- src/terminal-tabs-menu.c (revision 3169)
++++ src/terminal-tabs-menu.c (revision 3171)
+@@ -30,14 +30,16 @@
+ #include "terminal-screen-container.h"
+ #include "terminal-intl.h"
+
++#define TERMINAL_ACCELS_N_TABS_SWITCH (12)
++
+ #define LABEL_WIDTH_CHARS 32
+ #define ACTION_VERB_FORMAT_PREFIX "JmpTab"
+-#define ACTION_VERB_FORMAT_PREFIX_LEN (6) /* strlen (ACTION_VERB_FORMAT_PREFIX) */
+-#define ACTION_VERB_FORMAT ACTION_VERB_FORMAT_PREFIX "%x"
++#define ACTION_VERB_FORMAT_PREFIX_LEN strlen (ACTION_VERB_FORMAT_PREFIX)
++#define ACTION_VERB_FORMAT ACTION_VERB_FORMAT_PREFIX "%u"
+ #define ACTION_VERB_FORMAT_LENGTH strlen (ACTION_VERB_FORMAT) + 14 + 1
+ #define ACTION_VERB_FORMAT_BASE (16) /* %x is hex */
+-#define ACCEL_PATH_FORMAT "<Actions>/TabsActions/%s"
+-#define ACCEL_PATH_FORMAT_LENGTH strlen (ACCEL_PATH_FORMAT) -2 + ACTION_VERB_FORMAT_LENGTH
++#define ACCEL_PATH_FORMAT "<Actions>/Main/TabsSwitch%u"
++#define ACCEL_PATH_FORMAT_LENGTH strlen (ACCEL_PATH_FORMAT) + 14 + 1
+ #define DATA_KEY "TerminalTabsMenu::Action"
+
+ #define UI_PATH "/menubar/Tabs"
+@@ -379,7 +381,7 @@
+ g_type_class_add_private (object_class, sizeof (TerminalTabsMenuPrivate));
+
+ /* We don't want to save accels, so skip them */
+- gtk_accel_map_add_filter ("<Actions>/TabsActions/JmpTab*");
++ gtk_accel_map_add_filter ("<Actions>/Main/TabsSwitch*");
+ }
+
+ static void
+@@ -416,40 +418,19 @@
+ guint tab_number,
+ gboolean is_single_tab)
+ {
+- const char *verb;
+- char accel_path[ACCEL_PATH_FORMAT_LENGTH];
+- char accel[7];
+- gint accel_number;
+- guint accel_key;
+- GdkModifierType accel_mods;
++ if (!is_single_tab &&
++ tab_number < TERMINAL_ACCELS_N_TABS_SWITCH)
++ {
++ char accel_path[ACCEL_PATH_FORMAT_LENGTH];
+
+- verb = gtk_action_get_name (action);
+-
+- /* set the accel path for the menu item */
+- g_snprintf (accel_path, sizeof (accel_path),
+- ACCEL_PATH_FORMAT, verb);
+- gtk_action_set_accel_path (action, accel_path);
+-
+- /* Only the first ten tabs get accelerators starting from 1 through 0 */
+- if (tab_number < 10 && !is_single_tab)
+- {
+- accel_key = 0;
+- accel_number = (tab_number + 1) % 10;
+-
+- g_snprintf (accel, sizeof (accel), "<alt>%d", accel_number);
+-
+- gtk_accelerator_parse (accel, &accel_key, &accel_mods);
+-
+- if (accel_key != 0)
+- {
+- gtk_accel_map_change_entry (accel_path, accel_key,
+- accel_mods, TRUE);
+- }
+- }
+- else
+- {
+- gtk_accel_map_change_entry (accel_path, 0, 0, TRUE);
+- }
++ g_snprintf (accel_path, sizeof (accel_path), ACCEL_PATH_FORMAT, tab_number + 1);
++ gtk_action_set_accel_path (action, accel_path);
++ }
++ else
++ {
++ gtk_action_set_accel_path (action, NULL);
++ return;
++ }
+ }
+
+ static void
+Index: src/gnome-terminal.schemas.in
+===================================================================
+--- src/gnome-terminal.schemas.in (revision 3169)
++++ src/gnome-terminal.schemas.in (revision 3171)
+@@ -916,6 +916,210 @@
+ </schema>
+
+ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_1</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_1</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;1</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 1</short>
++ <long>
++ Keyboard shortcut key for switch to tab 1. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_2</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_2</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;2</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 2</short>
++ <long>
++ Keyboard shortcut key for switch to tab 2. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_3</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_3</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;3</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 3</short>
++ <long>
++ Keyboard shortcut key for switch to tab 3. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_4</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_4</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;4</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 4</short>
++ <long>
++ Keyboard shortcut key for switch to tab 4. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_5</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_5</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;5</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 5</short>
++ <long>
++ Keyboard shortcut key for switch to tab 5. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_6</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_6</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;6</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 6</short>
++ <long>
++ Keyboard shortcut key for switch to tab 6. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_7</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_7</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;7</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 7</short>
++ <long>
++ Keyboard shortcut key for switch to tab 7. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_8</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_8</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;8</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 8</short>
++ <long>
++ Keyboard shortcut key for switch to tab 8. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_9</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_9</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++ <default>&lt;Alt&gt;9</default>
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 9</short>
++ <long>
++ Keyboard shortcut key for switch to tab 9. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_10</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_10</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++<!-- no default -->
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 10</short>
++ <long>
++ Keyboard shortcut key for switch to tab 10. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_11</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_11</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++<!-- no default -->
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 11</short>
++ <long>
++ Keyboard shortcut key for switch to tab 11. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
++ <key>/schemas/apps/gnome-terminal/keybindings/switch_to_tab_12</key>
++ <applyto>/apps/gnome-terminal/keybindings/switch_to_tab_12</applyto>
++ <owner>gnome-terminal</owner>
++ <type>string</type>
++<!-- no default -->
++ <locale name="C">
++ <short>Keyboard shortcut to switch to tab 12</short>
++ <long>
++ Keyboard shortcut key for switch to tab 12. Expressed as a string
++ in the same format used for GTK+ resource files.
++ If you set the option to the special string "disabled", then there
++ will be no keyboard shortcut for this action.
++ </long>
++ </locale>
++ </schema>
++
++ <schema>
+ <key>/schemas/apps/gnome-terminal/keybindings/help</key>
+ <applyto>/apps/gnome-terminal/keybindings/help</applyto>
+ <owner>gnome-terminal</owner>
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.24.2.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.24.2.ebuild
new file mode 100644
index 000000000000..516bd4231a0e
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.24.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.24.2.ebuild,v 1.1 2008/12/01 09:44:35 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gnome-terminal-2.24.2-restore-switch-to-tab-i18n.patch.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="virtual/xft
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.13.6
+ >=gnome-base/gconf-2.14
+ >=x11-libs/startup-notification-0.8
+ >=x11-libs/vte-0.17.0
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ gnome-base/gnome-common
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Use login shell by default (#12900)
+ epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
+
+ # Restore switch to tab <n> keybinding preferences ...
+ epatch "${FILESDIR}/${P}-restore-switch-to-tab.patch"
+ # ... and the translations for it
+ epatch "${DISTDIR}/${P}-restore-switch-to-tab-i18n.patch.bz2"
+
+ # patch gnome terminal to report as GNOME rather than xterm
+ # This needs to resolve a few bugs (#120294,)
+ # Leave out for now; causing too many problems
+ #epatch ${FILESDIR}/${PN}-2.13.90-TERM-gnome.patch
+}