summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-11-10 16:39:13 +0000
committerNaohiro Aota <naota@gentoo.org>2011-11-10 16:39:13 +0000
commit76e0b27dc98090f226ce44077674b0e4a926e4a5 (patch)
treef10c5a9a11da13e9c8875da2286c9382d6db066c /x11-terms
parentbuild with newer zlib (bug #390093) (diff)
downloadgentoo-2-76e0b27dc98090f226ce44077674b0e4a926e4a5.tar.gz
gentoo-2-76e0b27dc98090f226ce44077674b0e4a926e4a5.tar.bz2
gentoo-2-76e0b27dc98090f226ce44077674b0e4a926e4a5.zip
Version bump. Bug #389237
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mlterm/ChangeLog8
-rw-r--r--x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch24
-rw-r--r--x11-terms/mlterm/mlterm-3.0.8.ebuild93
3 files changed, 124 insertions, 1 deletions
diff --git a/x11-terms/mlterm/ChangeLog b/x11-terms/mlterm/ChangeLog
index 8efe7e7bb9ae..4d4f2f79a3e5 100644
--- a/x11-terms/mlterm/ChangeLog
+++ b/x11-terms/mlterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/mlterm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.80 2011/10/28 07:56:49 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.81 2011/11/10 16:39:13 naota Exp $
+
+*mlterm-3.0.8 (10 Nov 2011)
+
+ 10 Nov 2011; Naohiro Aota <naota@gentoo.org> +mlterm-3.0.8.ebuild,
+ +files/mlterm-3.0.8-ldflags.patch:
+ Version bump. Bug #389237
*mlterm-3.0.7 (28 Oct 2011)
diff --git a/x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch b/x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch
new file mode 100644
index 000000000000..8e6092d292af
--- /dev/null
+++ b/x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch
@@ -0,0 +1,24 @@
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in mlterm-3.0.5/contrib/tool/mlcc/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlcc/Makefile.in 2011-06-09 23:29:02.851741057 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJECTS)
+- $(CC) -g -o $(PROG) $(OBJECTS)
++ $(CC) -g -o $(PROG) $(OBJECTS) $(LDFLAGS)
+
+ .SUFFIXES: .c.o
+
+diff -Naur mlterm-3.0.5.orig/tool/mlclient/Makefile.in mlterm-3.0.5/tool/mlclient/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlclient/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlclient/Makefile.in 2011-06-09 23:27:57.251467757 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJ)
+- $(CC) -o $(PROG) $(OBJ) $(LIBS)
++ $(CC) -o $(PROG) $(OBJ) $(LIBS) $(LDFLAGS)
+ cp $(PROG) $(PROG)x
+
+ .SUFFIXES: .c.o
diff --git a/x11-terms/mlterm/mlterm-3.0.8.ebuild b/x11-terms/mlterm/mlterm-3.0.8.ebuild
new file mode 100644
index 000000000000..d08e8c6e30d7
--- /dev/null
+++ b/x11-terms/mlterm/mlterm-3.0.8.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/mlterm-3.0.8.ebuild,v 1.1 2011/11/10 16:39:13 naota Exp $
+
+EAPI="3"
+inherit autotools eutils
+
+IUSE="bidi debug gtk ibus libssh2 m17n-lib nls scim static-libs uim xft"
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlterm/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="|| ( sys-libs/libutempter sys-apps/utempter )
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ gtk? ( x11-libs/gtk+:2 )
+ xft? ( x11-libs/libXft )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ ibus? ( >=app-i18n/ibus-1.3 )
+ libssh2? ( net-libs/libssh2 )
+ nls? ( virtual/libintl )
+ uim? ( >=app-i18n/uim-1.0 )
+ scim? ( >=app-i18n/scim-1.4 )
+ m17n-lib? ( >=dev-libs/m17n-lib-1.2.0 )"
+# vte? ( x11-libs/vte )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.9.4-uim15-fix.patch \
+ "${FILESDIR}"/${PN}-3.0.5-ibus.patch \
+ "${FILESDIR}"/${PN}-3.0.8-ldflags.patch \
+ "${FILESDIR}"/${PN}-3.0.7-underlinking.patch
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+
+ if use gtk ; then
+ myconf="${myconf} --with-imagelib=gdk-pixbuf"
+ else
+ myconf="${myconf} --with-tools=mlclient,mlcc"
+ fi
+
+ if use xft ; then
+ myconf="${myconf} --with-type-engines=xft"
+ else
+ myconf="${myconf} --with-type-engines=xcore"
+ fi
+
+ # iiimf isn't stable enough
+ #myconf="${myconf} $(use_enable iiimf)"
+
+ econf --enable-utmp \
+ $(use_enable bidi fribidi) \
+ $(use_enable debug) \
+ $(use_enable ibus) \
+ $(use_enable libssh2 ssh2) \
+ $(use_enable nls) \
+ $(use_enable uim) \
+ $(use_enable scim) \
+ $(use_enable m17n-lib m17nlib) \
+ $(use_enable static-libs static) \
+ ${myconf} || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ doicon contrib/icon/mlterm* || die
+ make_desktop_entry mlterm mlterm mlterm-icon TerminalEmulator || die
+
+ dodoc ChangeLog README || die
+
+ docinto ja
+ dodoc doc/ja/* || die
+ docinto en
+ dodoc doc/en/* || die
+}