summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-09-04 18:27:42 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-09-04 18:27:42 +0000
commit2c470e63a64f47bc5ce2c1d2b5c14635e7a25a83 (patch)
tree8c6e4ceda070f56235952a984929caad4c006a18 /x11-terms
parentStable on sparc (diff)
downloadgentoo-2-2c470e63a64f47bc5ce2c1d2b5c14635e7a25a83.tar.gz
gentoo-2-2c470e63a64f47bc5ce2c1d2b5c14635e7a25a83.tar.bz2
gentoo-2-2c470e63a64f47bc5ce2c1d2b5c14635e7a25a83.zip
add patch for new dbus
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/roxterm/ChangeLog6
-rw-r--r--x11-terms/roxterm/files/roxterm-1.2.3-dbus_close.patch12
-rw-r--r--x11-terms/roxterm/roxterm-1.2.3.ebuild5
3 files changed, 21 insertions, 2 deletions
diff --git a/x11-terms/roxterm/ChangeLog b/x11-terms/roxterm/ChangeLog
index 56771c983fd9..ee00cf20e1d7 100644
--- a/x11-terms/roxterm/ChangeLog
+++ b/x11-terms/roxterm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-terms/roxterm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/ChangeLog,v 1.1 2006/07/29 05:29:30 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/ChangeLog,v 1.2 2006/09/04 18:27:42 compnerd Exp $
+
+ 04 Sep 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/roxterm-1.2.3-dbus_close.patch, roxterm-1.2.3.ebuild:
+ add patch to drop deprecated calls in dbus
*roxterm-1.2.3 (29 Jul 2006)
diff --git a/x11-terms/roxterm/files/roxterm-1.2.3-dbus_close.patch b/x11-terms/roxterm/files/roxterm-1.2.3-dbus_close.patch
new file mode 100644
index 000000000000..072b13194f23
--- /dev/null
+++ b/x11-terms/roxterm/files/roxterm-1.2.3-dbus_close.patch
@@ -0,0 +1,12 @@
+diff -ruN roxterm-1.2.3.orig/src/rtdbus.c roxterm-1.2.3/src/rtdbus.c
+--- roxterm-1.2.3.orig/src/rtdbus.c 2006-07-28 15:55:31.000000000 -0500
++++ roxterm-1.2.3/src/rtdbus.c 2006-07-28 15:56:24.000000000 -0500
+@@ -41,7 +41,7 @@
+ {
+ if (disconnect)
+ {
+- dbus_connection_disconnect(rtdbus_connection);
++ dbus_connection_close(rtdbus_connection);
+ }
+ UNREF_LOG(dbus_connection_unref(rtdbus_connection));
+ rtdbus_connection = NULL;
diff --git a/x11-terms/roxterm/roxterm-1.2.3.ebuild b/x11-terms/roxterm/roxterm-1.2.3.ebuild
index 9648011f97ce..1815b0c2800d 100644
--- a/x11-terms/roxterm/roxterm-1.2.3.ebuild
+++ b/x11-terms/roxterm/roxterm-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/roxterm-1.2.3.ebuild,v 1.1 2006/07/29 05:29:30 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/roxterm-1.2.3.ebuild,v 1.2 2006/09/04 18:27:42 compnerd Exp $
inherit eutils
@@ -26,6 +26,9 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-1.2.3-new-button.patch
+
+ # Fix up DBUS function call to deprecated function
+ epatch ${FILESDIR}/${PN}-1.2.3-dbus_close.patch
}
src_install() {