summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-20 17:18:21 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-20 17:18:21 +0000
commit49490b1b46053497351df402b97788c454c71946 (patch)
treee98c7370bba8c94905d34e499ec28b035bb91ca1 /x11-proto
parentold (diff)
downloadgentoo-2-49490b1b46053497351df402b97788c454c71946.tar.gz
gentoo-2-49490b1b46053497351df402b97788c454c71946.tar.bz2
gentoo-2-49490b1b46053497351df402b97788c454c71946.zip
Bump for new tfp opcodes. Need to build xorg-server against this version if using mesa 6.5.1 and wanting nice compositing eye candy.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/glproto/ChangeLog9
-rw-r--r--x11-proto/glproto/files/digest-glproto-1.4.83
-rw-r--r--x11-proto/glproto/glproto-1.4.8.ebuild52
3 files changed, 63 insertions, 1 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index 16d8b7474456..dda38ba6e9f6 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.36 2006/07/19 14:25:54 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.37 2006/09/20 17:18:21 dberkholz Exp $
+
+*glproto-1.4.8 (20 Sep 2006)
+
+ 20 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +glproto-1.4.8.ebuild:
+ Bump for new tfp opcodes. Need to build xorg-server against this version if
+ using mesa 6.5.1 and wanting nice compositing eye candy.
19 Jul 2006; Guy Martin <gmsoft@gentoo.org> glproto-1.4.7.ebuild:
Stable on hppa.
diff --git a/x11-proto/glproto/files/digest-glproto-1.4.8 b/x11-proto/glproto/files/digest-glproto-1.4.8
new file mode 100644
index 000000000000..78696e106cb8
--- /dev/null
+++ b/x11-proto/glproto/files/digest-glproto-1.4.8
@@ -0,0 +1,3 @@
+MD5 3dfbd17203c0c88b94b6f579f24c11cc glproto-1.4.8.tar.bz2 53852
+RMD160 ff2250c6a1b5d9f900cc45dc8329dbc8c04c3433 glproto-1.4.8.tar.bz2 53852
+SHA256 2f5d84413853b688b7bb46c66fee108a499190e1f7810afffb775910778f053c glproto-1.4.8.tar.bz2 53852
diff --git a/x11-proto/glproto/glproto-1.4.8.ebuild b/x11-proto/glproto/glproto-1.4.8.ebuild
new file mode 100644
index 000000000000..4b9cb09eb24d
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.8.ebuild,v 1.1 2006/09/20 17:18:21 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-admin/eselect-opengl"
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}