summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-06-19 11:50:01 +0000
committerRémi Cardona <remi@gentoo.org>2009-06-19 11:50:01 +0000
commit24ea3a61cfb0edd92690de140ef88bcfcc1a296e (patch)
treec032bcc1a6df6e42648b8528b505c6fb9ea457dd /x11-proto
parentadd license/SGI-B-2.0 which is nearly identical to X11/MIT (diff)
downloadgentoo-2-24ea3a61cfb0edd92690de140ef88bcfcc1a296e.tar.gz
gentoo-2-24ea3a61cfb0edd92690de140ef88bcfcc1a296e.tar.bz2
gentoo-2-24ea3a61cfb0edd92690de140ef88bcfcc1a296e.zip
x11-proto/glproto: bump to 1.4.10, update license to SGI-B-2.0
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/glproto/ChangeLog7
-rw-r--r--x11-proto/glproto/glproto-1.4.10.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index a8a8e9566f28..b0162099d699 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.57 2009/05/05 15:11:36 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.58 2009/06/19 11:50:01 remi Exp $
+
+*glproto-1.4.10 (19 Jun 2009)
+
+ 19 Jun 2009; Rémi Cardona <remi@gentoo.org> +glproto-1.4.10.ebuild:
+ bump to 1.4.10, update license to SGI-B-2.0
05 May 2009; Christian Faulhammer <fauli@gentoo.org> glproto-1.4.8.ebuild,
glproto-1.4.9.ebuild:
diff --git a/x11-proto/glproto/glproto-1.4.10.ebuild b/x11-proto/glproto/glproto-1.4.10.ebuild
new file mode 100644
index 000000000000..1c69fdc3157e
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.10.ebuild,v 1.1 2009/06/19 11:50:01 remi Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+LICENSE="SGI-B-2.0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+RDEPEND="app-admin/eselect-opengl"
+DEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ for x in "${D}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}