summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-10 05:35:09 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-10 05:35:09 +0000
commit1269b81f3340fb179532137655996aa28f0af39c (patch)
tree10e2615c954d64fdc18a397d7ac870e81d0f3cfb /x11-proto
parentremove bogus digest file -KS (diff)
downloadgentoo-2-1269b81f3340fb179532137655996aa28f0af39c.tar.gz
gentoo-2-1269b81f3340fb179532137655996aa28f0af39c.tar.bz2
gentoo-2-1269b81f3340fb179532137655996aa28f0af39c.zip
Make compatible with opengl-update. Reported by Georgi Georgiev <chutz@gg3.net>.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/glproto/ChangeLog6
-rw-r--r--x11-proto/glproto/glproto-1.4.ebuild26
2 files changed, 30 insertions, 2 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index 992baec5d960..03425c8923e5 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.2 2005/08/08 17:54:50 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.3 2005/08/10 05:35:09 spyderous Exp $
+
+ 10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; glproto-1.4.ebuild:
+ Make compatible with opengl-update. Reported by Georgi Georgiev
+ <chutz@gg3.net>.
08 Aug 2005; Ferris McCormick <fmccor@gentoo.org> glproto-1.4.ebuild:
Add ~sparc keyword (modular X testing on sparc).
diff --git a/x11-proto/glproto/glproto-1.4.ebuild b/x11-proto/glproto/glproto-1.4.ebuild
index 5017eb4f5cea..41b40dd7314a 100644
--- a/x11-proto/glproto/glproto-1.4.ebuild
+++ b/x11-proto/glproto/glproto-1.4.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.ebuild,v 1.2 2005/08/08 17:54:50 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.ebuild,v 1.3 2005/08/10 05:35:09 spyderous Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
inherit x-modular
+OPENGL_DIR="xorg-x11"
+
DESCRIPTION="X.Org GL protocol headers"
#HOMEPAGE="http://foo.bar.com/"
#SRC_URI="ftp://foo.bar.com/${P}.tar.bz2"
@@ -16,3 +18,25 @@ KEYWORDS="~sparc ~x86"
#IUSE="X gnome"
#DEPEND=""
#RDEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ # glx.h also provided by mesa, so we don't add it
+ rm ${D}/usr/include/GL/glx.h
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}