summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-05-22 08:57:13 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-05-22 08:57:13 +0000
commitc974368b75045459619694675b3ba1fcb34bafc4 (patch)
tree46aa0979a63a00481cc7221980cad75647104ed5 /x11-proto/xcb-proto
parentVersion bump. (diff)
downloadgentoo-2-c974368b75045459619694675b3ba1fcb34bafc4.tar.gz
gentoo-2-c974368b75045459619694675b3ba1fcb34bafc4.tar.bz2
gentoo-2-c974368b75045459619694675b3ba1fcb34bafc4.zip
Enable installation of python module for multiple python ABIs, bug #470900
(Portage version: 2.1.12/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog7
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.8-r3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index c2a86076c91c..3f8074eb617c 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-proto/xcb-proto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.108 2013/04/10 19:52:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.109 2013/05/22 08:57:13 maksbotan Exp $
+
+*xcb-proto-1.8-r3 (22 May 2013)
+
+ 22 May 2013; Maxim Koltsov <maksbotan@gentoo.org> +xcb-proto-1.8-r3.ebuild:
+ Enable installation of python module for multiple python ABIs, bug #470900
10 Apr 2013; Agostino Sarubbo <ago@gentoo.org> xcb-proto-1.8-r1.ebuild:
Stable for s390, wrt bug #458992
diff --git a/x11-proto/xcb-proto/xcb-proto-1.8-r3.ebuild b/x11-proto/xcb-proto/xcb-proto-1.8-r3.ebuild
new file mode 100644
index 000000000000..6009528043ec
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.8-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.8-r3.ebuild,v 1.1 2013/05/22 08:57:13 maksbotan Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+src_configure() {
+ xorg-2_src_configure
+ #Note: multilib is not supported with python, therefore use only one ABI
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ xorg-2_src_compile
+
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${WORKDIR}/${P}-${ARCH}"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${WORKDIR}/${P}-${ARCH}"
+}
+
+pkg_postinst() {
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}