summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-08-16 19:17:16 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-08-16 19:17:16 +0000
commiteaff209fd6b64e142c2259a5b92cb0739c4d3045 (patch)
tree1bef19566238eefbe2a1b07c7ca0630f895179c8 /x11-plugins
parentVersion bump (diff)
downloadgentoo-2-eaff209fd6b64e142c2259a5b92cb0739c4d3045.tar.gz
gentoo-2-eaff209fd6b64e142c2259a5b92cb0739c4d3045.tar.bz2
gentoo-2-eaff209fd6b64e142c2259a5b92cb0739c4d3045.zip
Add correct libnotify patch for 0.8.8
(Portage version: 2.1.11.4/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/compiz-plugins-extra/ChangeLog7
-rw-r--r--x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild4
-rw-r--r--x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch19
3 files changed, 27 insertions, 3 deletions
diff --git a/x11-plugins/compiz-plugins-extra/ChangeLog b/x11-plugins/compiz-plugins-extra/ChangeLog
index 327f579c4f03..3ee6029a182c 100644
--- a/x11-plugins/compiz-plugins-extra/ChangeLog
+++ b/x11-plugins/compiz-plugins-extra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/compiz-plugins-extra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.19 2012/08/10 16:33:23 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.20 2012/08/16 19:17:15 maksbotan Exp $
+
+ 16 Aug 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/compiz-plugins-extra-0.8.8-libnotify.patch,
+ compiz-plugins-extra-0.8.8.ebuild:
+ Add correct libnotify patch for 0.8.8
*compiz-plugins-extra-0.8.8 (10 Aug 2012)
diff --git a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild
index 89ed257361ec..d2972fac9d2b 100644
--- a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild
+++ b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild,v 1.1 2012/08/10 16:33:23 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild,v 1.2 2012/08/16 19:17:15 maksbotan Exp $
EAPI="4"
@@ -48,7 +48,7 @@ src_configure() {
--enable-fast-install \
--disable-static \
$(use_enable gconf schemas) \
- $(use_with libnotify)
+ $(use_with libnotify notifications)
}
src_install() {
diff --git a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch
new file mode 100644
index 000000000000..9287d706ac8e
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch
@@ -0,0 +1,19 @@
+--- configure.ac 2011-04-21 15:51:08.000000000 +0400
++++ configure.ac 2012-08-16 21:37:46.894173595 +0400
+@@ -136,7 +136,15 @@
+ PKG_CHECK_MODULES(COMPIZMOUSEPOLL, compiz-mousepoll, [have_compiz_mousepoll=yes], [have_compiz_mousepoll=no])
+ AM_CONDITIONAL(SHOWMOUSE_PLUGIN, test "x$have_compiz_mousepoll" = "xyes")
+
+-PKG_CHECK_MODULES(LIBNOTIFY, libnotify gtk+-2.0, [have_libnotify=yes], [have_libnotify=no])
++AC_ARG_ENABLE(notifications, AS_HELP_STRING([--enable-notifications], [Build notification plugin]), [enable_notifications=$enableval], [enable_notification=auto])
++if test "$enable_notification" = auto; then
++ PKG_CHECK_MODULES(LIBNOTIFY, libnotify gtk+-2.0, [have_libnotify=yes], [have_libnotify=no])
++fi
++if test "$enable_notification" = yes; then
++ PKG_CHECK_MODULES(LIBNOTIFY, libnotify gtk+-2.0, [have_libnotify=yes], AC_MSG_ERROR([Libnotify is not installed]))
++else
++ have_libnotify=no
++fi
+ AM_CONDITIONAL(NOTIFICATION_PLUGIN, test "x$have_libnotify" = "xyes")
+ if test "$have_libnotify" = yes; then
+ AC_DEFINE(USE_NOTIFICATION, 1, [Build notification plugin])