summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-01-12 13:59:58 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-01-12 13:59:58 +0000
commitdc6cbcc3352c46be89a49c2ea6be276276ee17a0 (patch)
tree4b053fe16f6e216dea12dbc0aded5ed27e31dc57 /x11-plugins
parentAnd fix homepage (diff)
downloadgentoo-2-dc6cbcc3352c46be89a49c2ea6be276276ee17a0.tar.gz
gentoo-2-dc6cbcc3352c46be89a49c2ea6be276276ee17a0.tar.bz2
gentoo-2-dc6cbcc3352c46be89a49c2ea6be276276ee17a0.zip
Version bump with new homepage
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmitime/ChangeLog9
-rw-r--r--x11-plugins/wmitime/wmitime-0.4.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/x11-plugins/wmitime/ChangeLog b/x11-plugins/wmitime/ChangeLog
index 6e8356be7908..64306f702c2f 100644
--- a/x11-plugins/wmitime/ChangeLog
+++ b/x11-plugins/wmitime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmitime
-# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmitime/ChangeLog,v 1.15 2010/09/02 10:36:36 s4t4n Exp $
+# Copyright 2002-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmitime/ChangeLog,v 1.16 2015/01/12 13:59:58 voyageur Exp $
+
+*wmitime-0.4 (12 Jan 2015)
+
+ 12 Jan 2015; Bernard Cafarelli <voyageur@gentoo.org> +wmitime-0.4.ebuild:
+ Version bump with new homepage
02 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> makefile.diff:
Honour Gentoo LDFLAGS. Closes bug #335607.
diff --git a/x11-plugins/wmitime/wmitime-0.4.ebuild b/x11-plugins/wmitime/wmitime-0.4.ebuild
new file mode 100644
index 000000000000..90f227596b20
--- /dev/null
+++ b/x11-plugins/wmitime/wmitime-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmitime/wmitime-0.4.ebuild,v 1.1 2015/01/12 13:59:58 voyageur Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Overglorified clock dockapp w/time, date, and internet time"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmitime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/dockapps
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc BUGS CHANGES README
+}