summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2009-06-17 01:49:59 +0000
committerAngelo Arrifano <miknix@gentoo.org>2009-06-17 01:49:59 +0000
commitaee9770c2cff57f554ed109764ce59c5d44cd0e5 (patch)
tree21e39ffa6ac0896d5e2f5361cba5bbfd30142953 /x11-plugins
parentMasked beta release, containing DCC64 support, a more extensive CTCP command ... (diff)
downloadgentoo-2-aee9770c2cff57f554ed109764ce59c5d44cd0e5.tar.gz
gentoo-2-aee9770c2cff57f554ed109764ce59c5d44cd0e5.tar.bz2
gentoo-2-aee9770c2cff57f554ed109764ce59c5d44cd0e5.zip
Force autoreconf, see #274364.
Fix typo in dodoc Changelog. Shorten DESCRIPTION and add RDEPEND to make repoman happy. (Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/matchbox-desktop-xine/ChangeLog8
-rw-r--r--x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild16
2 files changed, 19 insertions, 5 deletions
diff --git a/x11-plugins/matchbox-desktop-xine/ChangeLog b/x11-plugins/matchbox-desktop-xine/ChangeLog
index 70f39ad2e92b..3311ffec62f3 100644
--- a/x11-plugins/matchbox-desktop-xine/ChangeLog
+++ b/x11-plugins/matchbox-desktop-xine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/matchbox-desktop-xine
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-desktop-xine/ChangeLog,v 1.3 2009/03/14 03:51:47 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-desktop-xine/ChangeLog,v 1.4 2009/06/17 01:49:59 miknix Exp $
+
+ 17 Jun 2009; Angelo Arrifano <miknix@gentoo.org>
+ matchbox-desktop-xine-0.4.ebuild:
+ Force autoreconf, see #274364.
+ Fix typo in dodoc Changelog.
+ Shorten DESCRIPTION and add RDEPEND to make repoman happy.
14 Mar 2009; <solar@gentoo.org> matchbox-desktop-xine-0.4.ebuild:
keyword ~amd64
diff --git a/x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild b/x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild
index cd6e50c3d664..a16ce376ef36 100644
--- a/x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild
+++ b/x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild
@@ -1,13 +1,13 @@
# Copyright 2006-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild,v 1.3 2009/03/14 03:51:47 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-desktop-xine/matchbox-desktop-xine-0.4.ebuild,v 1.4 2009/06/17 01:49:59 miknix Exp $
-inherit versionator eutils
+inherit versionator eutils autotools
MY_PN=${PN/matchbox/mb}
MY_P=${MY_PN}-${PV}
-DESCRIPTION="A matchbox-desktop plugin that allows you to browse and play movies and music. Its in pretty early stages and should probably be considered alpha software"
+DESCRIPTION="A matchbox-desktop plugin that allows you to browse and play media."
HOMEPAGE="http://matchbox-project.org/"
SRC_URI="http://matchbox-project.org/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
LICENSE="GPL-2"
@@ -19,9 +19,17 @@ IUSE="debug"
DEPEND=">=x11-libs/libmatchbox-1.1
x11-wm/matchbox-desktop
>=media-libs/xine-lib-1.0.0"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
src_compile () {
econf $(use_enable debug) || die "Configuration failed"
@@ -31,5 +39,5 @@ src_compile () {
src_install() {
make DESTDIR="${D}" install || die "Installation failed"
- dodoc AUTHORS Changelog INSTALL NEWS README
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
}