summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-01-25 16:14:19 +0000
committerJim Ramsay <lack@gentoo.org>2011-01-25 16:14:19 +0000
commit71c17541a23357f89ae3c75b6bdf264edeac2c89 (patch)
tree9f3c4b756035914b15e08ba6007659e4ca51c409 /x11-plugins
parentPort changes from Gentoo Prefix, use ED, add KEYWORDS. Fixes bug 352228 (diff)
downloadgentoo-2-71c17541a23357f89ae3c75b6bdf264edeac2c89.tar.gz
gentoo-2-71c17541a23357f89ae3c75b6bdf264edeac2c89.tar.bz2
gentoo-2-71c17541a23357f89ae3c75b6bdf264edeac2c89.zip
Applied user patch to fix LDFLAGS and CFLAGS issue (Bug #334453)
(Portage version: 2.1.9.34/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellmwireless/ChangeLog9
-rw-r--r--x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r1.ebuild25
2 files changed, 32 insertions, 2 deletions
diff --git a/x11-plugins/gkrellmwireless/ChangeLog b/x11-plugins/gkrellmwireless/ChangeLog
index bed7306b8262..8eeddab0e26c 100644
--- a/x11-plugins/gkrellmwireless/ChangeLog
+++ b/x11-plugins/gkrellmwireless/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrellmwireless
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmwireless/ChangeLog,v 1.18 2010/03/12 00:44:51 sping Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmwireless/ChangeLog,v 1.19 2011/01/25 16:14:19 lack Exp $
+
+*gkrellmwireless-2.0.3-r1 (25 Jan 2011)
+
+ 25 Jan 2011; Jim Ramsay <lack@gentoo.org> +gkrellmwireless-2.0.3-r1.ebuild:
+ Applied user patch to fix LDFLAGS and CFLAGS issue (Bug #334453)
12 Mar 2010; Sebastian Pipping <sping@gentoo.org>
gkrellmwireless-2.0.3.ebuild:
diff --git a/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r1.ebuild b/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..dafd37383b46
--- /dev/null
+++ b/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r1.ebuild,v 1.1 2011/01/25 16:14:19 lack Exp $
+
+EAPI=2
+inherit gkrellm-plugin toolchain-funcs
+
+IUSE=""
+S="${WORKDIR}/${PN}"
+DESCRIPTION="A plugin for GKrellM that monitors your wireless network card"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+HOMEPAGE="http://gkrellm.luon.net/gkrellmwireless.php"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+PLUGIN_SO=wireless.so
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/s:gcc $(CFLAGS) $(FLAGS):'"$(tc-getCC)"' $(FLAGS) $(CFLAGS):' \
+ -e '/-o wireless.so/s: : $(LDFLAGS) :' \
+ Makefile
+}