summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-08-30 00:28:32 +0000
committerJim Ramsay <lack@gentoo.org>2012-08-30 00:28:32 +0000
commit16778d1eedde34fe41c669e8d8bc2f19fb940934 (patch)
tree1ccc22bf8fb96bfd5067a049532631cfdb6ccd88 /x11-plugins
parentVersion bump: 0.1.11 (diff)
downloadgentoo-2-16778d1eedde34fe41c669e8d8bc2f19fb940934.tar.gz
gentoo-2-16778d1eedde34fe41c669e8d8bc2f19fb940934.tar.bz2
gentoo-2-16778d1eedde34fe41c669e8d8bc2f19fb940934.zip
Bug #363591: Version bump to 2.2.13
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrelltop/ChangeLog9
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild10
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild12
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild41
4 files changed, 57 insertions, 15 deletions
diff --git a/x11-plugins/gkrelltop/ChangeLog b/x11-plugins/gkrelltop/ChangeLog
index ecd0b45def08..163072784d7d 100644
--- a/x11-plugins/gkrelltop/ChangeLog
+++ b/x11-plugins/gkrelltop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gkrelltop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.36 2012/08/10 13:41:04 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.37 2012/08/30 00:28:32 lack Exp $
+
+*gkrelltop-2.2.13 (30 Aug 2012)
+
+ 30 Aug 2012; Jim Ramsay <jim_ramsay@gentoo.org> +gkrelltop-2.2.13.ebuild,
+ gkrelltop-2.2.11-r1.ebuild, gkrelltop-2.2.11.ebuild:
+ Bug #363591: Version bump to 2.2.13
10 Aug 2012; Johannes Huber <johu@gentoo.org> gkrelltop-2.2.11-r1.ebuild:
Stable for x86, wrt bug #422397
@@ -143,4 +149,3 @@
23 Oct 2003; Martin Holzer <mholzer@gentoo.org> gkrelltop-2.2.ebuild:
initial ebuild. submitted by Ciaran McCreesh <ciaranm@firedrop.org.uk> in
#29382.
-
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
index 4d2c3f60b0d8..e042375e3295 100644
--- a/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild,v 1.4 2012/08/10 13:41:04 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild,v 1.5 2012/08/30 00:28:32 lack Exp $
-EAPI=2
+EAPI=4
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
@@ -19,10 +19,8 @@ PLUGIN_SO=gkrelltop.so
S="${WORKDIR}/${P}.orig"
-RDEPEND="=app-admin/gkrellm-2*[X=]"
-DEPEND="${RDEPEND}
- =dev-libs/glib-2*
- X? ( =x11-libs/gtk+-2* )"
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
src_prepare() {
sed -i \
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
index 60ffa6c85ef5..848c19fd9b26 100644
--- a/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild,v 1.7 2009/09/05 22:35:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild,v 1.8 2012/08/30 00:28:32 lack Exp $
-EAPI=2
+EAPI=4
inherit gkrellm-plugin
DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
@@ -19,10 +19,8 @@ PLUGIN_SO=gkrelltop.so
S="${WORKDIR}/${P}.orig"
-RDEPEND="=app-admin/gkrellm-2*[X=]"
-DEPEND="${RDEPEND}
- =dev-libs/glib-2*
- X? ( =x11-libs/gtk+-2* )"
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
src_compile() {
use X || TARGET="server"
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild
new file mode 100644
index 000000000000..3ef741a67ffa
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild,v 1.1 2012/08/30 00:28:32 lack Exp $
+
+EAPI=4
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
+ -e 's/-shared/$(LDFLAGS) &/' \
+ Makefile || die
+}
+
+src_compile() {
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}