summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-04-08 09:03:59 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-04-08 09:03:59 +0000
commit04f3278714da872db9cd3239e251790d66f1d035 (patch)
tree19f7f4692ef3a854d4540b21ab25533bf8fcfa3f /x11-plugins
parentVersion bump (diff)
downloadgentoo-2-04f3278714da872db9cd3239e251790d66f1d035.tar.gz
gentoo-2-04f3278714da872db9cd3239e251790d66f1d035.tar.bz2
gentoo-2-04f3278714da872db9cd3239e251790d66f1d035.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/noscript/ChangeLog7
-rw-r--r--x11-plugins/noscript/noscript-1.5.8.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-plugins/noscript/ChangeLog b/x11-plugins/noscript/ChangeLog
index f5dcef3c734e..505eb8c20650 100644
--- a/x11-plugins/noscript/ChangeLog
+++ b/x11-plugins/noscript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/noscript
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.98 2008/03/31 09:39:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.99 2008/04/08 09:03:59 armin76 Exp $
+
+*noscript-1.5.8 (08 Apr 2008)
+
+ 08 Apr 2008; Raúl Porcel <armin76@gentoo.org> +noscript-1.5.8.ebuild:
+ Version bump
*noscript-1.5.6 (31 Mar 2008)
diff --git a/x11-plugins/noscript/noscript-1.5.8.ebuild b/x11-plugins/noscript/noscript-1.5.8.ebuild
new file mode 100644
index 000000000000..a5d2ff10aa7a
--- /dev/null
+++ b/x11-plugins/noscript/noscript-1.5.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/noscript-1.5.8.ebuild,v 1.1 2008/04/08 09:03:59 armin76 Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Firefox plugin to disable javascript"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+}