summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-01-13 12:28:22 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-01-13 12:28:22 +0000
commitf8256e0592ac9ee92a98abbae18b2cdb68eb094f (patch)
treeec03b2dc9f9a24085fdebcd2b35431607669df67 /x11-plugins/wmtime
parentVersion bump, drop old (diff)
downloadgentoo-2-f8256e0592ac9ee92a98abbae18b2cdb68eb094f.tar.gz
gentoo-2-f8256e0592ac9ee92a98abbae18b2cdb68eb094f.tar.bz2
gentoo-2-f8256e0592ac9ee92a98abbae18b2cdb68eb094f.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins/wmtime')
-rw-r--r--x11-plugins/wmtime/ChangeLog9
-rw-r--r--x11-plugins/wmtime/wmtime-1.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/x11-plugins/wmtime/ChangeLog b/x11-plugins/wmtime/ChangeLog
index 1c7fedab194a..19e8ee98c1cd 100644
--- a/x11-plugins/wmtime/ChangeLog
+++ b/x11-plugins/wmtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmtime
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtime/ChangeLog,v 1.6 2014/11/05 13:13:24 voyageur Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtime/ChangeLog,v 1.7 2015/01/13 12:28:22 voyageur Exp $
+
+*wmtime-1.2 (13 Jan 2015)
+
+ 13 Jan 2015; Bernard Cafarelli <voyageur@gentoo.org> +wmtime-1.2.ebuild:
+ Version bump
05 Nov 2014; Bernard Cafarelli <voyageur@gentoo.org> wmtime-1.1.ebuild:
Host tarball on my devspace, bug #527610
diff --git a/x11-plugins/wmtime/wmtime-1.2.ebuild b/x11-plugins/wmtime/wmtime-1.2.ebuild
new file mode 100644
index 000000000000..2b9425e36b52
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtime/wmtime-1.2.ebuild,v 1.1 2015/01/13 12:28:22 voyageur Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmtime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc BUGS CHANGES HINTS README TODO
+}