summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-09-03 09:24:12 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-09-03 09:24:12 +0000
commiteb4ef8cf71ee7ad27a68bcace32b053951e03fc8 (patch)
tree005572e0b8988e09da8dabaff0e4d0adf35aac1b /x11-plugins/wmpiki
parentquiet more QA warnings (diff)
downloadgentoo-2-eb4ef8cf71ee7ad27a68bcace32b053951e03fc8.tar.gz
gentoo-2-eb4ef8cf71ee7ad27a68bcace32b053951e03fc8.tar.bz2
gentoo-2-eb4ef8cf71ee7ad27a68bcace32b053951e03fc8.zip
Honour Gentoo LDFLAGS. Closes bug #335690.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmpiki')
-rw-r--r--x11-plugins/wmpiki/ChangeLog7
-rw-r--r--x11-plugins/wmpiki/wmpiki-0.2.1.ebuild14
2 files changed, 12 insertions, 9 deletions
diff --git a/x11-plugins/wmpiki/ChangeLog b/x11-plugins/wmpiki/ChangeLog
index 6c816f3b12ae..c38b2b20f6b3 100644
--- a/x11-plugins/wmpiki/ChangeLog
+++ b/x11-plugins/wmpiki/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmpiki
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpiki/ChangeLog,v 1.10 2009/04/28 14:50:20 s4t4n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpiki/ChangeLog,v 1.11 2010/09/03 09:24:12 s4t4n Exp $
+
+ 03 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> wmpiki-0.2.1.ebuild:
+ Honour Gentoo LDFLAGS. Closes bug #335690.
28 Apr 2009; Michele Noberasco <s4t4n@gentoo.org> wmpiki-0.2.1.ebuild:
Added some magic sed so that CC is no longer hardcoded, bug #215651.
diff --git a/x11-plugins/wmpiki/wmpiki-0.2.1.ebuild b/x11-plugins/wmpiki/wmpiki-0.2.1.ebuild
index 04ec22b4f5fa..ebef7e22fcce 100644
--- a/x11-plugins/wmpiki/wmpiki-0.2.1.ebuild
+++ b/x11-plugins/wmpiki/wmpiki-0.2.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpiki/wmpiki-0.2.1.ebuild,v 1.9 2009/04/28 14:50:20 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpiki/wmpiki-0.2.1.ebuild,v 1.10 2010/09/03 09:24:12 s4t4n Exp $
+EAPI=2
inherit eutils
IUSE=""
@@ -21,16 +22,15 @@ DEPEND="${RDEPEND}
x11-proto/xextproto
>=sys-apps/sed-4.1.4-r1"
-src_unpack()
+src_prepare()
{
- unpack ${A}
-
- sed -i 's/gcc/${CC}/' "${S}/Makefile"
+ sed -i 's/gcc/${CC}/' Makefile
+ sed -i 's/-o wmpiki/${LDFLAGS} -o wmpiki/' Makefile
}
src_compile()
{
- make CFLAGS="${CFLAGS}"|| die "Compilation failed"
+ make CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "Compilation failed"
}
src_install()