summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-09-15 10:29:15 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-09-15 10:29:15 +0000
commit294d887f12ef4842d61d42736cd98b2c22c8e8db (patch)
treed4aedc89a45d8407a0da5cc2f226645408f73aa5 /x11-plugins/wmail
parentMake ebuild completely Prefix aware (instead of half), fix wordview logic (in... (diff)
downloadgentoo-2-294d887f12ef4842d61d42736cd98b2c22c8e8db.tar.gz
gentoo-2-294d887f12ef4842d61d42736cd98b2c22c8e8db.tar.bz2
gentoo-2-294d887f12ef4842d61d42736cd98b2c22c8e8db.zip
Honour Gentoo LDFLAGS, see bug #337407.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmail')
-rw-r--r--x11-plugins/wmail/ChangeLog9
-rw-r--r--x11-plugins/wmail/wmail-2.0-r3.ebuild7
2 files changed, 11 insertions, 5 deletions
diff --git a/x11-plugins/wmail/ChangeLog b/x11-plugins/wmail/ChangeLog
index e422e9b4cb65..97a3dfee6acb 100644
--- a/x11-plugins/wmail/ChangeLog
+++ b/x11-plugins/wmail/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for x11-plugins/wmail
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/ChangeLog,v 1.20 2008/11/24 16:06:18 s4t4n Exp $
+# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/ChangeLog,v 1.21 2010/09/15 10:29:15 s4t4n Exp $
- 24 Nov 2008; Michele NOberasco <s4t4n@gentoo.org> wmail-2.0-r3.ebuild:
+ 15 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> wmail-2.0-r3.ebuild:
+ Honour Gentoo LDFLAGS, see bug #337407.
+
+ 24 Nov 2008; Michele Noberasco <s4t4n@gentoo.org> wmail-2.0-r3.ebuild:
Fixed LDFLAGS ordering, see bug #248620.
01 Dec 2007; nixnut <nixnut@gentoo.org> wmail-2.0-r3.ebuild:
diff --git a/x11-plugins/wmail/wmail-2.0-r3.ebuild b/x11-plugins/wmail/wmail-2.0-r3.ebuild
index fbd1e3791a46..f098879d424a 100644
--- a/x11-plugins/wmail/wmail-2.0-r3.ebuild
+++ b/x11-plugins/wmail/wmail-2.0-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/wmail-2.0-r3.ebuild,v 1.6 2008/11/24 16:06:18 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/wmail-2.0-r3.ebuild,v 1.7 2010/09/15 10:29:15 s4t4n Exp $
inherit eutils
@@ -29,6 +29,9 @@ src_unpack() {
# fix LDFLAGS ordering, see bug #248620
sed -i 's/$(LIBS) -o $@ $^/-o $@ $^ $(LIBS)/' "${S}/src/Makefile.in"
+
+ # Honour Gentoo LDFLAGS, see bug #337407
+ sed -i 's/-o $@ $^ $(LIBS)/$(LDFLAGS) -o $@ $^ $(LIBS)/' "${S}/src/Makefile.in"
}
src_compile() {