summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-19 15:18:25 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-19 15:18:25 +0000
commitecf6710d05d9d3e7735c93cf3fa2f9293d339001 (patch)
tree7c3ecf93285acfe29c5cdef786d861bf063ae1e8 /x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-ecf6710d05d9d3e7735c93cf3fa2f9293d339001.tar.gz
gentoo-2-ecf6710d05d9d3e7735c93cf3fa2f9293d339001.tar.bz2
gentoo-2-ecf6710d05d9d3e7735c93cf3fa2f9293d339001.zip
Revision bump, see bug #207762.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild')
-rw-r--r--x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild b/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
new file mode 100644
index 000000000000..f2bf46bd4279
--- /dev/null
+++ b/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmDownload/wmDownload-0.1.2a-r1.ebuild,v 1.1 2008/02/19 15:18:24 s4t4n Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="dockapp that displays how much data you've received on each eth and ppp device."
+SRC_URI="mirror://sourceforge/wmdownload/${P}.tar.gz"
+HOMEPAGE="http://wmdownload.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="x11-libs/libdockapp
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "compile failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc CHANGELOG CREDITS HINTS README TODO
+}