summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-09 09:33:43 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-09 09:33:43 +0000
commite80fa4926e61f2b72ca87262b15aeecb02ef71bb (patch)
tree9ac14f5b829a6714ac4f3a1c94af9e0069adf328 /x11-misc
parentPort to EAPI 3, correct runtime and build-time dependencies, make it respect ... (diff)
downloadgentoo-2-e80fa4926e61f2b72ca87262b15aeecb02ef71bb.tar.gz
gentoo-2-e80fa4926e61f2b72ca87262b15aeecb02ef71bb.tar.bz2
gentoo-2-e80fa4926e61f2b72ca87262b15aeecb02ef71bb.zip
Respect LDFLAGS wrt bug 336546. Thanks to Diego for the report. Fix implicit function declarations.
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/unclutter/ChangeLog11
-rw-r--r--x11-misc/unclutter/unclutter-8-r2.ebuild37
2 files changed, 46 insertions, 2 deletions
diff --git a/x11-misc/unclutter/ChangeLog b/x11-misc/unclutter/ChangeLog
index e049769294ae..3c4465f9b834 100644
--- a/x11-misc/unclutter/ChangeLog
+++ b/x11-misc/unclutter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/unclutter
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/unclutter/ChangeLog,v 1.24 2007/07/22 03:41:55 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/unclutter/ChangeLog,v 1.25 2010/09/09 09:33:43 xarthisius Exp $
+
+*unclutter-8-r2 (09 Sep 2010)
+
+ 09 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +unclutter-8-r2.ebuild:
+ Respect LDFLAGS wrt bug 336546. Thanks to Diego for the report. Fix
+ implicit function declarations.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
unclutter-8-r1.ebuild:
diff --git a/x11-misc/unclutter/unclutter-8-r2.ebuild b/x11-misc/unclutter/unclutter-8-r2.ebuild
new file mode 100644
index 000000000000..6fcfb4c0d3f5
--- /dev/null
+++ b/x11-misc/unclutter/unclutter-8-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/unclutter/unclutter-8-r2.ebuild,v 1.1 2010/09/09 09:33:43 xarthisius Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use."
+HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
+SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "/stdio/ a #include <stdlib.h>" unclutter.c || die #implictits
+}
+
+src_compile() {
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install () {
+ dobin unclutter || die
+ newman unclutter.man unclutter.1x || die
+ dodoc README || die
+}