summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-04 12:33:59 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-04 12:33:59 +0000
commitd22d03ae635416ac51ae022cff4510e18fcbe458 (patch)
tree7fcf88c75606585c1d9ff0a35ba4aa03309f7928 /x11-misc
parentDrop opencl use flag and install OpenCL unconditionally (diff)
downloadgentoo-2-d22d03ae635416ac51ae022cff4510e18fcbe458.tar.gz
gentoo-2-d22d03ae635416ac51ae022cff4510e18fcbe458.tar.bz2
gentoo-2-d22d03ae635416ac51ae022cff4510e18fcbe458.zip
Version bump, fixes bug 382077 by needle <qui_wan_chong@yahoo.de>
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xosview/ChangeLog10
-rw-r--r--x11-misc/xosview/files/xosview-1.9.2-emptyxpaths.patch46
-rw-r--r--x11-misc/xosview/xosview-1.9.2.ebuild44
3 files changed, 98 insertions, 2 deletions
diff --git a/x11-misc/xosview/ChangeLog b/x11-misc/xosview/ChangeLog
index 0e6ace04a2f2..c0f69b2c9a0e 100644
--- a/x11-misc/xosview/ChangeLog
+++ b/x11-misc/xosview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xosview
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.43 2011/08/16 06:15:27 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.44 2012/02/04 12:33:59 xarthisius Exp $
+
+*xosview-1.9.2 (04 Feb 2012)
+
+ 04 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/xosview-1.9.2-emptyxpaths.patch, +xosview-1.9.2.ebuild:
+ Version bump, fixes bug 382077 by needle <qui_wan_chong@yahoo.de>
16 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org> xosview-1.8.3-r1.ebuild,
+files/xosview-1.8.3-alpha-build-fix.patch:
diff --git a/x11-misc/xosview/files/xosview-1.9.2-emptyxpaths.patch b/x11-misc/xosview/files/xosview-1.9.2-emptyxpaths.patch
new file mode 100644
index 000000000000..9044bb1f708b
--- /dev/null
+++ b/x11-misc/xosview/files/xosview-1.9.2-emptyxpaths.patch
@@ -0,0 +1,46 @@
+--- config/configure.in.orig 2012-02-04 13:20:17.730436149 +0100
++++ config/configure.in 2012-02-04 13:21:05.333936874 +0100
+@@ -12,6 +12,20 @@
+ CXXFLAGS="$CXXFLAGS -I$x_includes"
+ fi
+
++#
++# On hpux10 both x_includes and x_libraries seem to be set to ""
++# This causes compiler options like '-I' and '-L', which break
++# the build. So, we avoid empty strings here.
++#
++if test -z "$x_includes"
++then
++ x_includes=.
++fi
++if test -z "$x_libraries"
++then
++ x_libraries=.
++fi
++
+ dnl
+ dnl Added a proper check for the snprintf() function
+ dnl
+@@ -381,22 +395,6 @@
+ AC_SUBST(USE_MOD_VERSIONS)
+ dnl Check for usleep(). Currently, only HP-UX doesn't have it.
+ AC_CHECK_FUNCS(usleep)
+-
+-#
+-# On hpux10 both x_includes and x_libraries seem to be set to ""
+-# This causes compiler options like '-I' and '-L', which break
+-# the build. So, we avoid empty strings here.
+-#
+-if test -z "$x_includes"
+-then
+- x_includes=.
+-fi
+-if test -z "$x_libraries"
+-then
+- x_libraries=.
+-fi
+-
+-
+ AC_SUBST(host_dir)
+ AC_OUTPUT(\
+ Makefile:config/Makefile.top.in \
diff --git a/x11-misc/xosview/xosview-1.9.2.ebuild b/x11-misc/xosview/xosview-1.9.2.ebuild
new file mode 100644
index 000000000000..1e6cd4a9ec8d
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.9.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/xosview-1.9.2.ebuild,v 1.1 2012/02/04 12:33:59 xarthisius Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -e 's:lib/X11/app:share/X11/app:g' \
+ -i Xrm.cc config/Makefile.top.in || die
+ sed -e 's:$(CFLAGS)::g' \
+ -i config/Makefile.config.in || die
+ epatch "${FILESDIR}"/${P}-emptyxpaths.patch
+ pushd config &> /dev/null
+ eautoreconf
+ cp configure ../ || die
+ popd &> /dev/null
+}
+
+src_install() {
+ dobin xosview
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+ doman *.1
+ dodoc CHANGES README README.linux TODO
+}