summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-02-20 02:07:20 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-02-20 02:07:20 +0000
commitb14c5834cae40161f7f5b2ce95ff55f8f903b8fa (patch)
tree3b6822adb26ebd2ca8293b2bc1dd5c85e848a7a0 /x11-misc
parentUse the correct directory for PAM modules. (diff)
downloadgentoo-2-b14c5834cae40161f7f5b2ce95ff55f8f903b8fa.tar.gz
gentoo-2-b14c5834cae40161f7f5b2ce95ff55f8f903b8fa.tar.bz2
gentoo-2-b14c5834cae40161f7f5b2ce95ff55f8f903b8fa.zip
Utilise pambase and general cleanup.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wdm/ChangeLog9
-rw-r--r--x11-misc/wdm/wdm-1.28-r2.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/x11-misc/wdm/ChangeLog b/x11-misc/wdm/ChangeLog
index f46a893cce28..a2539b556f07 100644
--- a/x11-misc/wdm/ChangeLog
+++ b/x11-misc/wdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/wdm
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/ChangeLog,v 1.29 2007/07/04 18:11:32 angelos Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/ChangeLog,v 1.30 2008/02/20 02:07:20 omp Exp $
+
+*wdm-1.28-r2 (20 Feb 2008)
+
+ 20 Feb 2008; David Shakaryan <omp@gentoo.org> +wdm-1.28-r2.ebuild:
+ Utilise pambase and general cleanup.
04 Jul 2007; Christoph Mende <angelos@gentoo.org> wdm-1.28-r1.ebuild:
Stable on amd64 wrt bug #183961
diff --git a/x11-misc/wdm/wdm-1.28-r2.ebuild b/x11-misc/wdm/wdm-1.28-r2.ebuild
new file mode 100644
index 000000000000..f775c4d6b17d
--- /dev/null
+++ b/x11-misc/wdm/wdm-1.28-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.28-r2.ebuild,v 1.1 2008/02/20 02:07:20 omp Exp $
+
+inherit pam
+
+DESCRIPTION="WINGs Display Manager"
+HOMEPAGE="http://voins.program.ru/wdm/"
+SRC_URI="http://voins.program.ru/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="truetype pam selinux"
+
+RDEPEND=">=x11-wm/windowmaker-0.70.0
+ truetype? ( virtual/xft )
+ x11-libs/libXt
+ x11-libs/libXpm
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+RDEPEND="${RDEPEND}
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+
+src_compile() {
+ econf \
+ --exec-prefix=/usr \
+ --with-wdmdir=/etc/X11/wdm \
+ $(use_enable pam)\
+ $(use_enable selinux) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}/etc/pam.d/wdm"
+ pamd_mimic system-local-login wdm auth account password session
+}