summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-07-04 04:26:03 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-07-04 04:26:03 +0000
commit9724a641160ba8184d3ff3a9f93f378cc1d7a85e (patch)
tree269a8ee94dc7a5e75ad7cf91d92042cc61c4de7c /x11-misc
parentFixed typo that shouldn't affect compiles (diff)
downloadgentoo-2-9724a641160ba8184d3ff3a9f93f378cc1d7a85e.tar.gz
gentoo-2-9724a641160ba8184d3ff3a9f93f378cc1d7a85e.tar.bz2
gentoo-2-9724a641160ba8184d3ff3a9f93f378cc1d7a85e.zip
Some old XKB thing (xkbdata?) installed /usr/share/X11/xkb/symbols/pc as a directory. Now we install it as a file, but portage won't let a file replace a directory so it doesn't get installed. This breaks XKB setups, with numerous reports. Check for the directory in pkg_setup().
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog9
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild11
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index 9af5374d6a6f..0ea81a0f52da 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.16 2006/06/30 23:50:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.17 2006/07/04 04:26:03 spyderous Exp $
+
+ 04 Jul 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ xkeyboard-config-0.8.ebuild:
+ Some old XKB thing (xkbdata?) installed /usr/share/X11/xkb/symbols/pc as a
+ directory. Now we install it as a file, but portage won't let a file replace
+ a directory so it doesn't get installed. This breaks XKB setups, with
+ numerous reports. Check for the directory in pkg_setup().
30 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
xkeyboard-config-0.8.ebuild:
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild
index 24fde90c774a..fdffec4cdee0 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild,v 1.5 2006/06/30 23:50:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild,v 1.6 2006/07/04 04:26:03 spyderous Exp $
inherit eutils multilib
@@ -23,6 +23,15 @@ pkg_setup() {
eerror "manually deleted/renamed/relocated before installing!"
die "Manually remove ${DIR}"
fi
+
+ # The old xkbdata 'pc' directory can screw stuff up, because portage won't
+ # let us overwrite a directory with a file
+ local PC="${ROOT}usr/share/X11/xkb/symbols/pc"
+ if [[ -d ${PC} ]] ; then
+ eerror "Directory ${PC} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${PC}"
+ fi
}
src_compile() {