summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-15 22:58:27 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-15 22:58:27 +0000
commit960aa63c267aaaa5c2c618b800ca76846e830149 (patch)
tree95fa36945d21cb718696b01a9c9420b1312813b0 /x11-misc
parentold (diff)
downloadgentoo-2-960aa63c267aaaa5c2c618b800ca76846e830149.tar.gz
gentoo-2-960aa63c267aaaa5c2c618b800ca76846e830149.tar.bz2
gentoo-2-960aa63c267aaaa5c2c618b800ca76846e830149.zip
Fix bug 251779 with ebuild from Michael Mair-Keimberger <miki3@gmx.net>. Also solves bug 193309.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/efax-gtk/ChangeLog11
-rw-r--r--x11-misc/efax-gtk/efax-gtk-3.0.18.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/x11-misc/efax-gtk/ChangeLog b/x11-misc/efax-gtk/ChangeLog
index 706a70751065..e03f0546dbbc 100644
--- a/x11-misc/efax-gtk/ChangeLog
+++ b/x11-misc/efax-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/efax-gtk
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/efax-gtk/ChangeLog,v 1.26 2007/04/20 21:29:01 josejx Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/efax-gtk/ChangeLog,v 1.27 2009/02/15 22:58:27 loki_val Exp $
+
+*efax-gtk-3.0.18 (15 Feb 2009)
+
+ 15 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +efax-gtk-3.0.18.ebuild:
+ Fix bug 251779 with ebuild from Michael Mair-Keimberger <miki3@gmx.net>.
+ Also solves bug 193309.
20 Apr 2007; Joseph Jezak <josejx@gentoo.org> efax-gtk-3.0.11.ebuild:
Marked ~ppc for bug #173832.
diff --git a/x11-misc/efax-gtk/efax-gtk-3.0.18.ebuild b/x11-misc/efax-gtk/efax-gtk-3.0.18.ebuild
new file mode 100644
index 000000000000..a063afc2f1ce
--- /dev/null
+++ b/x11-misc/efax-gtk/efax-gtk-3.0.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/efax-gtk/efax-gtk-3.0.18.ebuild,v 1.1 2009/02/15 22:58:27 loki_val Exp $
+
+DESCRIPTION="GTK+2 frontend for the efax program."
+HOMEPAGE="http://efax-gtk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/libsigc++-2
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ # The binaries
+ dobin src/efax-gtk
+ dobin efax/efax-0.9a
+ dobin efax/efix-0.9a
+
+ # The man page
+ doman efax-gtk.1
+
+ # Native Language Support (NLS)
+ if use nls; then
+ for gmo in po/*.gmo; do
+ cp --force $gmo $(echo $gmo | sed 's:\.g:\.:')
+ done
+ domo po/*.mo
+ fi
+
+ # The spool directory and print filter
+ dodir /var/spool/fax
+ fowners lp:lp /var/spool/fax
+ insinto /var/spool/fax
+ insopts -m755 -oroot -groot
+ doins efax-gtk-faxfilter/efax-gtk-faxfilter
+ doins efax-gtk-faxfilter/efax-gtk-socket-client
+
+ # Config file
+ insinto /etc
+ doins efax-gtkrc
+
+ # Docs
+ dodoc AUTHORS BUGS ChangeLog README
+}