summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-04-13 23:27:55 +0000
committerBen de Groot <yngwin@gentoo.org>2008-04-13 23:27:55 +0000
commit8a5e597304a3061e822f96858bea4f17545cc7e9 (patch)
tree3087246cc02ac0f88175c0970c46a2e8b51200a8 /x11-misc
parentAdding x11-misc/xvidcap-1.1.7_rc1 to ffmpeg new include layout mask (diff)
downloadgentoo-2-8a5e597304a3061e822f96858bea4f17545cc7e9.tar.gz
gentoo-2-8a5e597304a3061e822f96858bea4f17545cc7e9.tar.bz2
gentoo-2-8a5e597304a3061e822f96858bea4f17545cc7e9.zip
Adding xvidcap-1.1.4_rc1, patched to work with new ffmpeg
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xvidcap/ChangeLog11
-rw-r--r--x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-ffmpeg.patch149
-rw-r--r--x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-new-ffmpeg-headers.patch49
-rw-r--r--x11-misc/xvidcap/xvidcap-1.1.7_rc1.ebuild55
4 files changed, 263 insertions, 1 deletions
diff --git a/x11-misc/xvidcap/ChangeLog b/x11-misc/xvidcap/ChangeLog
index 382c2f086665..c6c54cf98bdb 100644
--- a/x11-misc/xvidcap/ChangeLog
+++ b/x11-misc/xvidcap/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-misc/xvidcap
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvidcap/ChangeLog,v 1.40 2008/01/07 03:55:47 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvidcap/ChangeLog,v 1.41 2008/04/13 23:27:54 yngwin Exp $
+
+*xvidcap-1.1.7_rc1 (13 Apr 2008)
+
+ 13 Apr 2008; Ben de Groot <yngwin@gentoo.org>
+ +files/xvidcap-1.1.7_rc1-ffmpeg.patch,
+ +files/xvidcap-1.1.7_rc1-new-ffmpeg-headers.patch,
+ +xvidcap-1.1.7_rc1.ebuild:
+ New rc version, patched to work with new ffmpeg. Masked until new ffmpeg
+ is unmasked.
07 Jan 2008; David Shakaryan <omp@gentoo.org> xvidcap-1.1.4_rc1.ebuild:
Add dev-util/pkgconfig to DEPEND. (bug #204579)
diff --git a/x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-ffmpeg.patch b/x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-ffmpeg.patch
new file mode 100644
index 000000000000..067d63eabc15
--- /dev/null
+++ b/x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-ffmpeg.patch
@@ -0,0 +1,149 @@
+Index: src/xtoffmpeg.c
+===================================================================
+--- src/xtoffmpeg.c (Revision 302)
++++ src/xtoffmpeg.c (Arbeitskopie)
+@@ -58,6 +58,7 @@
+ // ffmpeg stuff
+ #include <ffmpeg/avcodec.h>
+ #include <ffmpeg/avformat.h>
++#include <ffmpeg/avdevice.h>
+ //#include <ffmpeg/dsputil.h>
+ #include <ffmpeg/swscale.h>
+ #include <ffmpeg/rgb2rgb.h>
+@@ -291,13 +292,13 @@
+
+ // prepare input stream
+ memset (ap, 0, sizeof (*ap));
+- ap->device = job->snd_device;
++// ap->device = job->snd_device;
+
+ if (grab_audio) {
+ ap->sample_rate = target->sndrate;
+ ap->channels = target->sndchannels;
+
+- grab_iformat = av_find_input_format ("audio_device");
++ grab_iformat = av_find_input_format ("oss");
+ #ifdef DEBUG
+ printf ("%s %s: grab iformat %p\n", DEBUGFILE, DEBUGFUNCTION,
+ grab_iformat);
+@@ -308,7 +309,7 @@
+ }
+
+ err =
+- av_open_input_file (&ic, ap->device, (grab_audio ? grab_iformat : NULL),
++ av_open_input_file (&ic, job->snd_device, (grab_audio ? grab_iformat : NULL),
+ 0, ap);
+ if (err < 0) {
+ fprintf (stderr, _("%s %s: error opening input file %s: %i\n"),
+@@ -1432,7 +1433,8 @@
+ input_pixfmt = guess_input_pix_fmt (image, job->c_info);
+
+ // register all libav* related stuff
+- av_register_all ();
++ avdevice_register_all();
++ av_register_all();
+
+ // guess AVOutputFormat
+ if (job->target >= CAP_MF)
+@@ -1763,7 +1765,7 @@
+ }
+
+ if (job->target < CAP_MF)
+- url_fclose (&output_file->pb);
++ url_fclose (output_file->pb);
+
+ #ifdef HAVE_FFMPEG_AUDIO
+ /*
+@@ -1828,7 +1830,7 @@
+ * close file if multi-frame capture ... otherwise closed already
+ */
+ if (job->target >= CAP_MF)
+- url_fclose (&output_file->pb);
++ url_fclose (output_file->pb);
+ /*
+ * free streams
+ */
+Index: configure.in
+===================================================================
+--- configure.in (Revision 302)
++++ configure.in (Arbeitskopie)
+@@ -103,6 +103,7 @@
+ rm ffmpeg/adler32.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/avcodec.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/avutil.h >/dev/null 2>&1 || echo "" > /dev/null
++rm ffmpeg/avdevice.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/common.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/dsputil.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/integer.h >/dev/null 2>&1 || echo "" > /dev/null
+@@ -118,6 +119,8 @@
+ rm ffmpeg/rtspcodes.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/rtp_h264.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/rtp_internal.h >/dev/null 2>&1 || echo "" > /dev/null
++rm ffmpeg/rtp_aac.h >/dev/null 2>&1 || echo "" > /dev/null
++rm ffmpeg/rtp_mpv.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/fifo.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/swscale.h >/dev/null 2>&1 || echo "" > /dev/null
+ rm ffmpeg/rgb2rgb.h >/dev/null 2>&1 || echo "" > /dev/null
+@@ -356,7 +359,7 @@
+ # build embedded ffmpeg
+ echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && \
+ ( cd ./ffmpeg/ && \
+- ./configure --cc=${CC} --enable-gpl ${ac_my_ffmpeg_cfg_lib_switch} --enable-pthreads --enable-swscaler --disable-ffserver --disable-ffplay && \
++ ./configure --cc=${CC} --enable-gpl ${ac_my_ffmpeg_cfg_lib_switch} --enable-pthreads --enable-swscale --disable-ffserver --disable-ffplay && \
+ ln -s libavcodec/avcodec.h ./ && \
+ ln -s libavcodec/dsputil.h ./ && \
+ ln -s libavformat/avformat.h ./ && \
+@@ -371,11 +374,12 @@
+ ln -s libavutil/fifo.h ./ && \
+ ln -s libswscale/swscale.h ./ && \
+ ln -s libswscale/rgb2rgb.h ./ && \
++ ln -s libavdevice/avdevice.h ./ && \
+ ${MAKE-make} )
+ # try to link it statically, or reset cache, set static_avcodec=no
+ top_srcdir=`pwd`
+- ac_my_ldflags_save=${LDFLAGS} ; LDFLAGS="${LDFLAGS} -L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat -L$top_srcdir/ffmpeg/libavutil -L$top_srcdir/ffmpeg/libswscale"
+- ac_my_cflags_save=${CFLAGS} ; CFLAGS="${CFLAGS} -I $top_srcdir -I[$top_srcdir]/ffmpeg/libavcodec -I[$top_srcdir]/ffmpeg/libavformat -I[$top_srcdir]/ffmpeg/libavutil -I[$top_srcdir]/ffmpeg/libswscale"
++ ac_my_ldflags_save=${LDFLAGS} ; LDFLAGS="${LDFLAGS} -L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat -L$top_srcdir/ffmpeg/libavutil -L$top_srcdir/ffmpeg/libswscale -L$top_srcdir/ffmpeg/libavdevice"
++ ac_my_cflags_save=${CFLAGS} ; CFLAGS="${CFLAGS} -I $top_srcdir -I[$top_srcdir]/ffmpeg/libavcodec -I[$top_srcdir]/ffmpeg/libavformat -I[$top_srcdir]/ffmpeg/libavutil -I[$top_srcdir]/ffmpeg/libswscale -I[$top_srcdir]/ffmpeg/libavdevice"
+ AC_CHECK_LIB_STATIC(avutil, av_rescale,,[unset ac_cv_lib_avutil_av_rescale ; static_avcodec=no ; LDFLAGS=$ac_my_ldflags_save ; CFLAGS=$ac_my_cflags_save])
+ fi
+
+@@ -392,16 +396,21 @@
+
+ # if avutil is linked statically, avcodec should, too
+ static_avcodec=$static_avutil
+-ac_my_avcodec_libs=""
+-test x`(uname -s)` = xSunOS && ac_my_avcodec_libs="-lnsl -lsocket"
++ac_my_avcodec_libs="-lz"
++test x`(uname -s)` = xSunOS && ac_my_avcodec_libs="-lz -lnsl -lsocket"
+ AC_CHECK_LIB_STATIC(avcodec, avcodec_encode_video,,[unset ac_cv_lib_avcodec_avcodec_encode_video ; static_avcodec=no ; AC_CHECK_LIB(avcodec, avcodec_encode_video,,,[$ac_my_avcodec_libs])],[$ac_my_avcodec_libs])
+
+ # if avcodec is linked statically, avformat should, too
+ static_avformat=$static_avcodec
+-ac_my_avformat_libs=""
+-test x`(uname -s)` = xSunOS && ac_my_avformat_libs="-lnsl -lsocket"
++ac_my_avformat_libs="-lz"
++test x`(uname -s)` = xSunOS && ac_my_avformat_libs="-lz -lnsl -lsocket"
+ AC_CHECK_LIB_STATIC(avformat, av_write_header,,[unset ac_cv_lib_avformat_av_write_header ; static_avformat=no ; AC_CHECK_LIB(avformat, av_write_header,,,[$ac_my_avformat_libs])],[$ac_my_avformat_libs])
+
++# if avcodec is linked statically, avdevice should, too
++static_avdevice=$static_avcodec
++ac_my_avdevice_libs="-lz"
++test x`(uname -s)` = xSunOS && ac_my_avdevice_libs="-lz -lnsl -lsocket"
++AC_CHECK_LIB_STATIC(avdevice, avdevice_register_all,,[unset ac_cv_lib_avdevice_avdevice_register_all ; static_avdevice=no ; AC_CHECK_LIB(avdevice, avdevice_register_all,,,[$ac_my_avdevice_libs])],[$ac_my_avdevice_libs])
+
+ # only use ffmpeg if ALL required libs are present
+ if ( `test x$ac_cv_lib_avcodec_avcodec_encode_video = xyes -a x$ac_cv_lib_avformat_av_write_header = xyes -a x$ac_cv_lib_avutil_av_rescale = xyes -a x$ac_cv_lib_swscale_sws_scale = xyes` ) ; then
+Index: config.h.in
+===================================================================
+--- config.h.in (Revision 302)
++++ config.h.in (Arbeitskopie)
+@@ -51,6 +51,9 @@
+ /* Define to 1 if you have the `avcodec' library (-lavcodec). */
+ #undef HAVE_LIBAVCODEC
+
++/* Define to 1 if you have the `avdevice' library (-lavdevice). */
++#undef HAVE_LIBAVDEVICE
++
+ /* Define to 1 if you have the `avformat' library (-lavformat). */
+ #undef HAVE_LIBAVFORMAT
diff --git a/x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-new-ffmpeg-headers.patch b/x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-new-ffmpeg-headers.patch
new file mode 100644
index 000000000000..4d4da99d04d5
--- /dev/null
+++ b/x11-misc/xvidcap/files/xvidcap-1.1.7_rc1-new-ffmpeg-headers.patch
@@ -0,0 +1,49 @@
+diff -burN xvidcap-orig/src/codecs.c xvidcap-1.1.6/src/codecs.c
+--- xvidcap-orig/src/codecs.c 2007-12-16 23:01:38.000000000 +0100
++++ xvidcap-1.1.6/src/codecs.c 2008-04-13 22:21:45.000000000 +0200
+@@ -43,8 +43,8 @@
+ #include <locale.h>
+
+ #ifdef USE_FFMPEG
+-#include <ffmpeg/avcodec.h>
+-#include <ffmpeg/avformat.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
+ #endif // USE_FFMPEG
+
+ #include "app_data.h"
+diff -burN xvidcap-orig/src/main.c xvidcap-1.1.6/src/main.c
+--- xvidcap-orig/src/main.c 2007-12-01 00:52:51.000000000 +0100
++++ xvidcap-1.1.6/src/main.c 2008-04-13 22:21:14.000000000 +0200
+@@ -45,7 +45,7 @@
+ #include <locale.h>
+
+ #ifdef USE_FFMPEG
+-#include <ffmpeg/avcodec.h>
++#include <libavcodec/avcodec.h>
+ #endif // USE_FFMPEG
+
+ #include "control.h"
+diff -burN xvidcap-orig/src/xtoffmpeg.c xvidcap-1.1.6/src/xtoffmpeg.c
+--- xvidcap-orig/src/xtoffmpeg.c 2008-04-13 22:00:04.000000000 +0200
++++ xvidcap-1.1.6/src/xtoffmpeg.c 2008-04-13 22:20:31.000000000 +0200
+@@ -56,13 +56,13 @@
+ #include "xvidcap-intl.h"
+
+ // ffmpeg stuff
+-#include <ffmpeg/avcodec.h>
+-#include <ffmpeg/avformat.h>
+-#include <ffmpeg/avdevice.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
++#include <libavdevice/avdevice.h>
+ //#include <ffmpeg/dsputil.h>
+-#include <ffmpeg/swscale.h>
+-#include <ffmpeg/rgb2rgb.h>
+-#include <ffmpeg/fifo.h>
++#include <libswscale/swscale.h>
++#include <libswscale/rgb2rgb.h>
++#include <libavutil/fifo.h>
+ #define swscale_isRGB(x) ((x)==PIX_FMT_BGR32 || (x)==PIX_FMT_RGB24 \
+ || (x)==PIX_FMT_RGB565 || (x)==PIX_FMT_RGB555 \
+ || (x)==PIX_FMT_RGB8 || (x)==PIX_FMT_RGB4 \
diff --git a/x11-misc/xvidcap/xvidcap-1.1.7_rc1.ebuild b/x11-misc/xvidcap/xvidcap-1.1.7_rc1.ebuild
new file mode 100644
index 000000000000..2b40f101fadf
--- /dev/null
+++ b/x11-misc/xvidcap/xvidcap-1.1.7_rc1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvidcap/xvidcap-1.1.7_rc1.ebuild,v 1.1 2008/04/13 23:27:54 yngwin Exp $
+
+GCONF_DEBUG="no"
+
+inherit eutils autotools gnome2
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="Screen capture utility enabling you to create videos of your desktop for illustration or documentation purposes."
+HOMEPAGE="http://xvidcap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mp3 theora"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ gnome-base/libglade
+ >=media-video/ffmpeg-0.4.9_p20080326
+ mp3? ( media-sound/lame )
+ theora? ( media-libs/libtheora )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ virtual/libintl
+ app-text/scrollkeeper
+ dev-perl/XML-Parser
+ app-text/gnome-doc-utils"
+
+S=${WORKDIR}/${PN}-1.1.6
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ffmpeg.patch
+ epatch "${FILESDIR}"/${P}-new-ffmpeg-headers.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf --without-forced-embedded-ffmpeg \
+ $(use_enable mp3 libmp3lame) \
+ $(use_enable theora libtheora)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || "emake install failed."
+
+ # Almost like bug #58322 but directory name changed.
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog README TODO.tasks
+}