summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-07 14:24:09 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-07 14:24:09 +0000
commit61dc7e8596415dcb589fabb4663d59a9619762ff (patch)
tree0337ffcbd85e62ae224f31354a3168fc35064ed1 /x11-misc
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-61dc7e8596415dcb589fabb4663d59a9619762ff.tar.gz
gentoo-2-61dc7e8596415dcb589fabb4663d59a9619762ff.tar.bz2
gentoo-2-61dc7e8596415dcb589fabb4663d59a9619762ff.zip
Version bump, drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/colord/ChangeLog8
-rw-r--r--x11-misc/colord/colord-1.2.10.ebuild171
-rw-r--r--x11-misc/colord/colord-1.2.5.ebuild123
3 files changed, 178 insertions, 124 deletions
diff --git a/x11-misc/colord/ChangeLog b/x11-misc/colord/ChangeLog
index 21553991acc0..2a72c4079bdb 100644
--- a/x11-misc/colord/ChangeLog
+++ b/x11-misc/colord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/colord
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/ChangeLog,v 1.99 2015/03/29 18:19:23 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/ChangeLog,v 1.100 2015/06/07 14:24:09 pacho Exp $
+
+*colord-1.2.10 (07 Jun 2015)
+
+ 07 Jun 2015; Pacho Ramos <pacho@gentoo.org> +colord-1.2.10.ebuild,
+ -colord-1.2.5.ebuild:
+ Version bump, drop old
29 Mar 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
-colord-1.2.5-r1.ebuild, -colord-1.2.8.ebuild, colord-1.2.9.ebuild:
diff --git a/x11-misc/colord/colord-1.2.10.ebuild b/x11-misc/colord/colord-1.2.10.ebuild
new file mode 100644
index 000000000000..3b9e825261fc
--- /dev/null
+++ b/x11-misc/colord/colord-1.2.10.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/colord-1.2.10.ebuild,v 1.1 2015/06/07 14:24:09 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools bash-completion-r1 check-reqs eutils gnome2 user systemd udev vala multilib-minimal
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/2" # subslot = libcolord soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# We prefer policykit enabled by default, bug #448058
+IUSE="argyllcms examples extra-print-profiles +gusb +introspection +policykit scanner systemd +udev vala"
+REQUIRED_USE="
+ gusb? ( udev )
+ scanner? ( udev )
+ vala? ( introspection )
+"
+
+COMMON_DEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=media-libs/lcms-2.6:2=[${MULTILIB_USEDEP}]
+ argyllcms? ( media-gfx/argyllcms )
+ gusb? ( >=dev-libs/libgusb-0.2.2[introspection?,${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+ policykit? ( >=sys-auth/polkit-0.103 )
+ scanner? (
+ media-gfx/sane-backends
+ sys-apps/dbus )
+ systemd? ( >=sys-apps/systemd-44:0= )
+ udev? (
+ virtual/udev
+ virtual/libgudev:=
+ virtual/libudev:=[${MULTILIB_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !media-gfx/shared-color-profiles
+ !<=media-gfx/colorhug-client-0.1.13
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ extra-print-profiles? ( media-gfx/argyllcms )
+ vala? ( $(vala_depend) )
+"
+
+# FIXME: needs pre-installed dbus service files
+RESTRICT="test"
+
+# According to upstream comment in colord.spec.in, building the extra print
+# profiles requires >=4G of memory
+CHECKREQS_MEMORY="4G"
+
+pkg_pretend() {
+ use extra-print-profiles && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use extra-print-profiles && check-reqs_pkg_setup
+ enewgroup colord
+ enewuser colord -1 -1 /var/lib/colord colord
+}
+
+src_prepare() {
+ # Adapt to Gentoo paths
+ sed -i -e 's/spotread/argyll-spotread/' \
+ src/sensors/cd-sensor-argyll.c \
+ configure.ac || die
+
+ eautoreconf
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # Reverse tools require gusb
+ # bash-completion test does not work on gentoo
+ local myconf=(
+ --disable-bash-completion
+ --disable-examples
+ --disable-static
+ --enable-libcolordcompat
+ --with-daemon-user=colord
+ --localstatedir="${EPREFIX}"/var
+ $(multilib_native_use_enable argyllcms argyllcms-sensor)
+ $(multilib_native_use_enable extra-print-profiles print-profiles)
+ $(multilib_native_usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "")
+ $(use_enable gusb)
+ $(multilib_native_use_enable gusb reverse)
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable policykit polkit)
+ $(multilib_native_use_enable scanner sane)
+ $(multilib_native_use_enable systemd systemd-login)
+ $(use_enable udev)
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+ $(multilib_native_use_enable vala)
+ "$(systemd_with_unitdir)"
+ )
+
+ if ! multilib_is_native_abi; then
+ # disable some extraneous checks
+ myconf+=(
+ SQLITE_{CFLAGS,LIBS}=' '
+ GUDEV_{CFLAGS,LIBS}=' '
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ gnome2_src_compile
+ else
+ emake -C lib/colord
+ use gusb && emake -C lib/colorhug
+ emake -C lib/compat
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C lib/colord check
+ use gusb && emake -C lib/colorhug check
+ emake -C lib/compat check
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ gnome2_src_install
+ else
+ gnome2_src_install -C lib/colord
+ use gusb && gnome2_src_install -C lib/colorhug
+ gnome2_src_install -C lib/compat
+ gnome2_src_install -C contrib/session-helper install-libcolord_includeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README.md TODO"
+ einstalldocs
+
+ newbashcomp data/colormgr colormgr
+
+ # Ensure config and profile directories exist and /var/lib/colord/*
+ # is writable by colord user
+ keepdir /var/lib/color{,d}/icc
+ fowners colord:colord /var/lib/colord{,/icc}
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}
diff --git a/x11-misc/colord/colord-1.2.5.ebuild b/x11-misc/colord/colord-1.2.5.ebuild
deleted file mode 100644
index 4c6470342576..000000000000
--- a/x11-misc/colord/colord-1.2.5.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/colord-1.2.5.ebuild,v 1.4 2014/12/19 13:44:12 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.18"
-
-inherit bash-completion-r1 check-reqs eutils gnome2 user systemd udev vala
-
-DESCRIPTION="System service to accurately color manage input and output devices"
-HOMEPAGE="http://www.freedesktop.org/software/colord/"
-SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0/2" # subslot = libcolord soname version
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-
-# We prefer policykit enabled by default, bug #448058
-IUSE="examples extra-print-profiles +gusb +introspection +policykit scanner systemd +udev vala"
-REQUIRED_USE="
- gusb? ( udev )
- scanner? ( udev )
- vala? ( introspection )
-"
-
-COMMON_DEPEND="
- dev-db/sqlite:3=
- >=dev-libs/glib-2.36:2
- >=media-libs/lcms-2.6:2=
- gusb? ( >=dev-libs/libgusb-0.1.1[introspection?] )
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- policykit? ( >=sys-auth/polkit-0.103 )
- scanner? ( media-gfx/sane-backends )
- systemd? ( >=sys-apps/systemd-44:0= )
- udev? (
- virtual/udev
- virtual/libgudev:=
- virtual/libudev:=
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !media-gfx/shared-color-profiles
- !<=media-gfx/colorhug-client-0.1.13
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- extra-print-profiles? ( media-gfx/argyllcms )
- vala? ( $(vala_depend) )
-"
-
-# FIXME: needs pre-installed dbus service files
-RESTRICT="test"
-
-# According to upstream comment in colord.spec.in, building the extra print
-# profiles requires >=4G of memory
-CHECKREQS_MEMORY="4G"
-
-pkg_pretend() {
- use extra-print-profiles && check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- use extra-print-profiles && check-reqs_pkg_setup
- enewgroup colord
- enewuser colord -1 -1 /var/lib/colord colord
-}
-
-src_prepare() {
- # Adapt to Gentoo paths
- sed -i -e 's/spotread/argyll-spotread/' src/sensors/cd-sensor-argyll.c || die
-
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # Reverse tools require gusb
- # bash-completion test does not work on gentoo
- gnome2_src_configure \
- --disable-bash-completion \
- --disable-examples \
- --disable-static \
- --enable-libcolordcompat \
- --with-daemon-user=colord \
- --localstatedir="${EPREFIX}"/var \
- $(use_enable extra-print-profiles print-profiles) \
- $(usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "") \
- $(use_enable gusb) \
- $(use_enable gusb reverse) \
- $(use_enable introspection) \
- $(use_enable policykit polkit) \
- $(use_enable scanner sane) \
- $(use_enable systemd systemd-login) \
- $(use_enable udev) \
- --with-udevrulesdir="$(get_udevdir)"/rules.d \
- $(use_enable vala) \
- "$(systemd_with_unitdir)"
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README.md TODO"
- gnome2_src_install
-
- newbashcomp data/colormgr colormgr
- rm -vr "${ED}etc/bash_completion.d"
-
- # Ensure config and profile directories exist and /var/lib/colord/*
- # is writable by colord user
- keepdir /var/lib/color{,d}/icc
- fowners colord:colord /var/lib/colord{,/icc}
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.c
- fi
-}