summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-10-15 06:38:49 +0000
committerMichael Weber <xmw@gentoo.org>2012-10-15 06:38:49 +0000
commit5e45dbea768be775a95797a30d6f79caf5d95c4c (patch)
tree3c06206e6e97840c73bf4aa5d651805ee5c54449 /x11-misc
parentVersion bump. (diff)
downloadgentoo-2-5e45dbea768be775a95797a30d6f79caf5d95c4c.tar.gz
gentoo-2-5e45dbea768be775a95797a30d6f79caf5d95c4c.tar.bz2
gentoo-2-5e45dbea768be775a95797a30d6f79caf5d95c4c.zip
Version bump (by polynomial-c, bug 438152)
(Portage version: 2.1.11.26/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xosview/ChangeLog7
-rw-r--r--x11-misc/xosview/xosview-1.11.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/xosview/ChangeLog b/x11-misc/xosview/ChangeLog
index 7af3c775ac61..291f796d6c38 100644
--- a/x11-misc/xosview/ChangeLog
+++ b/x11-misc/xosview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xosview
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.56 2012/10/04 00:49:46 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.57 2012/10/15 06:38:49 xmw Exp $
+
+*xosview-1.11 (15 Oct 2012)
+
+ 15 Oct 2012; Michael Weber <xmw@gentoo.org> +xosview-1.11.ebuild:
+ Version bump (by polynomial-c, bug 438152)
04 Oct 2012; Anthony G. Basile <blueness@gentoo.org> xosview-1.9.4.ebuild:
stable ppc ppc64, bug #436988
diff --git a/x11-misc/xosview/xosview-1.11.ebuild b/x11-misc/xosview/xosview-1.11.ebuild
new file mode 100644
index 000000000000..f994fa65a334
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/xosview-1.11.ebuild,v 1.1 2012/10/15 06:38:49 xmw Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -e 's:lib/X11/app:share/X11/app:g' \
+ -i xosview.1 || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+ doman *.1
+ dodoc CHANGES README.linux TODO
+}
+
+pkg_postinst() {
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}