summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-22 07:01:57 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-22 07:01:57 +0000
commit496a77169c5b5cb310d665b05acd73bc16fbd15d (patch)
treebd94bc08f5386fc4cb2704b76f42d3b4fdba6733 /x11-misc
parentFix build as per Bug #481678 (diff)
downloadgentoo-2-496a77169c5b5cb310d665b05acd73bc16fbd15d.tar.gz
gentoo-2-496a77169c5b5cb310d665b05acd73bc16fbd15d.tar.bz2
gentoo-2-496a77169c5b5cb310d665b05acd73bc16fbd15d.zip
Fix completion (bug #526344).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wbar/ChangeLog8
-rw-r--r--x11-misc/wbar/files/wbar-2.3.4-completion.patch19
-rw-r--r--x11-misc/wbar/wbar-2.3.4-r2.ebuild54
3 files changed, 80 insertions, 1 deletions
diff --git a/x11-misc/wbar/ChangeLog b/x11-misc/wbar/ChangeLog
index 359eda081335..46d12185406a 100644
--- a/x11-misc/wbar/ChangeLog
+++ b/x11-misc/wbar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wbar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.33 2014/08/10 20:04:28 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.34 2014/10/22 07:01:57 jer Exp $
+
+*wbar-2.3.4-r2 (22 Oct 2014)
+
+ 22 Oct 2014; Jeroen Roovers <jer@gentoo.org> +wbar-2.3.4-r2.ebuild,
+ +files/wbar-2.3.4-completion.patch:
+ Fix completion (bug #526344).
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> wbar-1.3.3.ebuild,
wbar-2.2.2.ebuild:
diff --git a/x11-misc/wbar/files/wbar-2.3.4-completion.patch b/x11-misc/wbar/files/wbar-2.3.4-completion.patch
new file mode 100644
index 000000000000..218d33442a9e
--- /dev/null
+++ b/x11-misc/wbar/files/wbar-2.3.4-completion.patch
@@ -0,0 +1,19 @@
+--- a/etc/wbar
++++ b/etc/wbar
+@@ -1,7 +1,6 @@
+ # bash completion for wbar
+ # Yadickson Soto yadickson@gmail.com
+
+-have wbar &&
+ _wbar()
+ {
+ local cur prev split=false
+@@ -106,7 +105,7 @@
+ -- "$cur") )
+
+ fi
+-} &&
++}
+ complete -F _wbar wbar
+
+ # Local variables:
diff --git a/x11-misc/wbar/wbar-2.3.4-r2.ebuild b/x11-misc/wbar/wbar-2.3.4-r2.ebuild
new file mode 100644
index 000000000000..2da87ab2c569
--- /dev/null
+++ b/x11-misc/wbar/wbar-2.3.4-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.3.4-r2.ebuild,v 1.1 2014/10/22 07:01:57 jer Exp $
+
+EAPI=5
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="A fast, lightweight quick launch bar"
+HOMEPAGE="http://code.google.com/p/wbar/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11
+ gtk? ( gnome-base/libglade
+ media-libs/freetype:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ use gtk || epatch "${FILESDIR}"/${PN}-2.3.3-cfg.patch
+
+ epatch \
+ "${FILESDIR}"/${PN}-2.3.3-{desktopfile,nowerror,test}.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch \
+ "${FILESDIR}"/${P}-completion.patch
+
+ sed -i \
+ -e "/^bashcompletiondir/s:=.*$:=$(get_bashcompdir):" \
+ etc/Makefile.am || die #482358
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk wbar-config)
+}
+
+pkg_postinst() {
+ einfo
+ elog "media-libs/imlib2 needs to be compiled with the appropriate useflags"
+ elog "depending on your choice of image files (such as png, jpeg...)"
+ einfo
+}