summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-02-21 19:19:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-02-21 19:19:24 +0000
commita245767c90edec717725d4e4b23e98500c895dff (patch)
treea1970af4b2d32ff6fe8669032261da0b7d606149 /x11-misc/xmobar
parentsparc stable wrt bug #492138 (diff)
downloadgentoo-2-a245767c90edec717725d4e4b23e98500c895dff.tar.gz
gentoo-2-a245767c90edec717725d4e4b23e98500c895dff.tar.bz2
gentoo-2-a245767c90edec717725d4e4b23e98500c895dff.zip
Version bump.
(Portage version: 2.2.8_p51/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'x11-misc/xmobar')
-rw-r--r--x11-misc/xmobar/ChangeLog10
-rw-r--r--x11-misc/xmobar/files/xmobar-0.19-ghc-7.8.patch32
-rw-r--r--x11-misc/xmobar/xmobar-0.19.ebuild67
3 files changed, 107 insertions, 2 deletions
diff --git a/x11-misc/xmobar/ChangeLog b/x11-misc/xmobar/ChangeLog
index 736489c44f31..09e212ae0881 100644
--- a/x11-misc/xmobar/ChangeLog
+++ b/x11-misc/xmobar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xmobar
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.24 2013/07/23 18:24:08 slyfox Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.25 2014/02/21 19:19:24 slyfox Exp $
+
+*xmobar-0.19 (21 Feb 2014)
+
+ 21 Feb 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/xmobar-0.19-ghc-7.8.patch, +xmobar-0.19.ebuild:
+ Version bump.
23 Jul 2013; Sergei Trofimovich <slyfox@gentoo.org> xmobar-0.18.ebuild:
Remove USE=inotify as USE=mail always did mail notifications via hinotify (bug
diff --git a/x11-misc/xmobar/files/xmobar-0.19-ghc-7.8.patch b/x11-misc/xmobar/files/xmobar-0.19-ghc-7.8.patch
new file mode 100644
index 000000000000..50d9af358528
--- /dev/null
+++ b/x11-misc/xmobar/files/xmobar-0.19-ghc-7.8.patch
@@ -0,0 +1,32 @@
+commit 21782da09df74bb96128636c10f55bff135d66af
+Author: Jose Antonio Ortega Ruiz <jao@gnu.org>
+Date: Mon Nov 25 00:51:44 2013 +0100
+
+ findFiles renamed for directory-1.2.0.2 compat (fixes #137)
+
+diff --git a/src/Plugins/Monitors/CoreCommon.hs b/src/Plugins/Monitors/CoreCommon.hs
+index c7fb7d5..5d6efd4 100644
+--- a/src/Plugins/Monitors/CoreCommon.hs
++++ b/src/Plugins/Monitors/CoreCommon.hs
+@@ -35,7 +35,8 @@ retrieveData :: (Ord a, Num a)
+ => [String] -> Maybe (String, String -> Int)
+ -> (Double -> a) -> (a -> String) -> Monitor (Maybe String)
+ retrieveData path lbl trans fmt = do
+- pairs <- map snd . sortBy (compare `on` fst) <$> (mapM readFiles =<< findFiles path lbl)
++ pairs <- map snd . sortBy (compare `on` fst) <$>
++ (mapM readFiles =<< findFilesAndLabel path lbl)
+ if null pairs
+ then return Nothing
+ else Just <$> ( parseTemplate
+@@ -84,9 +85,9 @@ pathComponents = joinComps . drop 2 . intercalate [Space] . map splitParts
+
+ -- | Function to find all files matching the given path and possible label file.
+ -- The path must be absolute (start with a leading slash).
+-findFiles :: [String] -> Maybe (String, String -> Int)
++findFilesAndLabel :: [String] -> Maybe (String, String -> Int)
+ -> Monitor [(String, Either Int (String, String -> Int))]
+-findFiles path lbl = catMaybes
++findFilesAndLabel path lbl = catMaybes
+ <$> ( mapM addLabel . zip [0..] . sort
+ =<< recFindFiles (pathComponents path) "/"
+ )
diff --git a/x11-misc/xmobar/xmobar-0.19.ebuild b/x11-misc/xmobar/xmobar-0.19.ebuild
new file mode 100644
index 000000000000..130fe59f69cf
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.19.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.19.ebuild,v 1.1 2014/02/21 19:19:24 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5
+#hackport: flags: -all_extensions,+with_threaded,+with_utf8,with_iwlib:wifi,with_alsa:alsa,with_xft:xft,with_datezone:timezone,with_dbus:dbus,with_mpd:mpd,with_inotify:inotify,with_mpris:mpris
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://projects.haskell.org/xmobar/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus inotify mpd mpris timezone wifi xft"
+
+RDEPEND="x11-libs/libXrandr
+ wifi? ( net-wireless/wireless-tools )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-2.2
+ >=dev-haskell/parsec-3.1 <dev-haskell/parsec-3.2
+ dev-haskell/regex-compat
+ >=dev-haskell/stm-2.3 <dev-haskell/stm-2.5
+ >=dev-haskell/utf8-string-0.3 <dev-haskell/utf8-string-0.4
+ >=dev-haskell/x11-1.6.1
+ >=dev-lang/ghc-6.12.1
+ alsa? ( >=dev-haskell/alsa-core-0.5 <dev-haskell/alsa-core-0.6
+ >=dev-haskell/alsa-mixer-0.1 <dev-haskell/alsa-mixer-0.2 )
+ dbus? ( >=dev-haskell/dbus-0.10 )
+ inotify? ( >=dev-haskell/hinotify-0.3 <dev-haskell/hinotify-0.4 )
+ mpd? ( >=dev-haskell/libmpd-0.8 <dev-haskell/libmpd-0.9 )
+ mpris? ( >=dev-haskell/dbus-0.10 )
+ timezone? ( >=dev-haskell/timezone-olson-0.1 <dev-haskell/timezone-olson-0.2
+ >=dev-haskell/timezone-series-0.1 <dev-haskell/timezone-series-0.2 )
+ xft? ( >=dev-haskell/x11-xft-0.2 <dev-haskell/x11-xft-0.4 )
+"
+RDEPEND+="mpd? ( media-sound/mpd )"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-7.8.patch)
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-all_extensions \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag timezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ $(cabal_flag inotify with_inotify) \
+ $(cabal_flag wifi with_iwlib) \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ --flag=with_threaded \
+ --flag=with_utf8 \
+ $(cabal_flag xft with_xft)
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc samples/xmobar.config readme.md news.md
+}