summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-01-03 02:38:36 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-01-03 02:38:36 +0000
commit4c4afef49b8c3f5af9747df41216ed98cf9a3a44 (patch)
treea7153a71f65b2757612fe2f5f13f6bae2f814068 /x11-misc/xac
parentamd64 stable, bug 128688 (diff)
downloadgentoo-2-4c4afef49b8c3f5af9747df41216ed98cf9a3a44.tar.gz
gentoo-2-4c4afef49b8c3f5af9747df41216ed98cf9a3a44.tar.bz2
gentoo-2-4c4afef49b8c3f5af9747df41216ed98cf9a3a44.zip
New version of xac. Includes interactive mode (not yet complete), PS3 support and lots of bug fixes.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'x11-misc/xac')
-rw-r--r--x11-misc/xac/ChangeLog10
-rw-r--r--x11-misc/xac/files/digest-xac-0.6_pre13
-rw-r--r--x11-misc/xac/xac-0.6_pre1.ebuild50
3 files changed, 61 insertions, 2 deletions
diff --git a/x11-misc/xac/ChangeLog b/x11-misc/xac/ChangeLog
index 5be13be3760b..a8b35724948d 100644
--- a/x11-misc/xac/ChangeLog
+++ b/x11-misc/xac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xac
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/ChangeLog,v 1.2 2006/08/31 13:03:38 corsair Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/ChangeLog,v 1.3 2007/01/03 02:38:36 josejx Exp $
+
+*xac-0.6_pre1 (03 Jan 2007)
+
+ 03 Jan 2007; Joseph Jezak <josejx@gentoo.org> +xac-0.6_pre1.ebuild:
+ New version of xac. Includes interactive mode (not yet complete), PS3
+ support and lots of bug fixes.
31 Aug 2006; Markus Rothe <corsair@gentoo.org> xac-0.5.ebuild:
Added ~ppc64
diff --git a/x11-misc/xac/files/digest-xac-0.6_pre1 b/x11-misc/xac/files/digest-xac-0.6_pre1
new file mode 100644
index 000000000000..1ee872e7cd04
--- /dev/null
+++ b/x11-misc/xac/files/digest-xac-0.6_pre1
@@ -0,0 +1,3 @@
+MD5 2663c1599291cdf085a9b50d64e28350 xac-0.6_pre1.tar.bz2 37354
+RMD160 8ad91a89019be277a79955387d3a9e85b43081e7 xac-0.6_pre1.tar.bz2 37354
+SHA256 e9f23c1d4be448cce3a71315fb414fa4aec7b5bf7bd743505fd2c11edd70d481 xac-0.6_pre1.tar.bz2 37354
diff --git a/x11-misc/xac/xac-0.6_pre1.ebuild b/x11-misc/xac/xac-0.6_pre1.ebuild
new file mode 100644
index 000000000000..55951d5830c6
--- /dev/null
+++ b/x11-misc/xac/xac-0.6_pre1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/xac-0.6_pre1.ebuild,v 1.1 2007/01/03 02:38:36 josejx Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
+HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3
+ sys-apps/pciutils"
+RDEPEND=">=dev-lang/python-2.3
+ || ( x11-base/xorg-server virtual/x11 )"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+src_compile() {
+ ### Replace /usr/lib/xac with libdir version
+ cd "${S}"
+ sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
+
+ ### Compile the C bindings
+ cd "${S}"/src
+ ### I'm not sure of a better way to do this yet
+ if use x86 || use amd64; then
+ sed -i "s:if 1:if 0:" setup.py || die "Enabling VBE module failed!"
+ fi
+ ./setup.py build || die "Failed to build the C modules"
+}
+
+src_install() {
+ local xac_base="/usr/$(get_libdir)/xac"
+
+ dosbin "${S}"/xac
+
+ ### Install the C mods
+ cd "${S}"/src
+ ./setup.py install --root "${D}" || die "Failed to install the C modules"
+
+ dodir "${xac_base}"
+ insinto ${xac_base}
+ doins "${S}"/py/*
+
+ exeinto /etc/init.d
+ newexe "${S}"/xac.init xac
+ insinto /etc/conf.d
+ newins "${S}"/xac.conf xac
+}