summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-10 18:28:37 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-10 18:28:37 +0000
commit72623d0c2f14c9144f9f77ec396fdd70acd41f1d (patch)
tree177ce9899b643b52ff1b2188a5a93cad1f794eff /x11-misc/wmakerconf
parentadded missing dep for doc USE-flag, x86 stable per bug 402953 (diff)
downloadgentoo-2-72623d0c2f14c9144f9f77ec396fdd70acd41f1d.tar.gz
gentoo-2-72623d0c2f14c9144f9f77ec396fdd70acd41f1d.tar.bz2
gentoo-2-72623d0c2f14c9144f9f77ec396fdd70acd41f1d.zip
Support new windowmaker (small API update and function name collision)
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/ChangeLog10
-rw-r--r--x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch124
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild54
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.12.ebuild6
4 files changed, 189 insertions, 5 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
index 15366d0b51e0..0baf136cf840 100644
--- a/x11-misc/wmakerconf/ChangeLog
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wmakerconf
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.38 2011/03/22 19:31:10 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.39 2012/02/10 18:28:36 voyageur Exp $
+
+*wmakerconf-2.12-r1 (10 Feb 2012)
+
+ 10 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> wmakerconf-2.12.ebuild,
+ +wmakerconf-2.12-r1.ebuild, +files/wmakerconf-2.12-wmaker-0.95_support.patch:
+ Support new windowmaker (small API update and function name collision)
22 Mar 2011; Jonathan Callen <abcd@gentoo.org> wmakerconf-2.12.ebuild:
Bump to EAPI=3, merge prefix changes, add ~x86-linux/~amd64-linux
diff --git a/x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch b/x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch
new file mode 100644
index 000000000000..7964be3a8022
--- /dev/null
+++ b/x11-misc/wmakerconf/files/wmakerconf-2.12-wmaker-0.95_support.patch
@@ -0,0 +1,124 @@
+diff -Naur wmakerconf-2.12.orig/src/menu.c wmakerconf-2.12/src/menu.c
+--- wmakerconf-2.12.orig/src/menu.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/menu.c 2012-02-10 17:35:03.917287748 +0100
+@@ -500,10 +500,10 @@
+ * No return value.
+ */
+ {
+- if (!WMWritePropListToFile (orig_wmaker, orig_wmaker_fname, YES))
++ if (!WMWritePropListToFile(orig_wmaker, orig_wmaker_fname))
+ warning (_("Can't revert to backupfile of `WindowMaker'. "
+ "Please manually revert from file WindowMaker.bak."));
+- if (orig_rootmenu && !WMWritePropListToFile (orig_rootmenu, orig_rootmenu_fname, YES))
++ if (orig_rootmenu && !WMWritePropListToFile(orig_rootmenu, orig_rootmenu_fname))
+ warning (_("Can't revert to backupfile of `WMRootMenu'. "
+ "Please manually revert from file WMRootMenu.bak."));
+ gtk_main_quit ();
+diff -Naur wmakerconf-2.12.orig/src/misc.c wmakerconf-2.12/src/misc.c
+--- wmakerconf-2.12.orig/src/misc.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/misc.c 2012-02-10 17:35:45.456051883 +0100
+@@ -463,7 +463,7 @@
+ }
+
+ bool_t
+-copy_file (const char *dst, const char *src)
++wmconf_copy_file (const char *dst, const char *src)
+ /*
+ * Copy file 'src' to file or directory 'dst' (works like cp).
+ * If the operation fails, show a popup error window.
+diff -Naur wmakerconf-2.12.orig/src/misc.h wmakerconf-2.12/src/misc.h
+--- wmakerconf-2.12.orig/src/misc.h 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/misc.h 2012-02-10 17:35:48.063974284 +0100
+@@ -72,7 +72,7 @@
+ char *
+ protect_quotes (char *string);
+ bool_t
+-copy_file (const char *dst, const char *src);
++wmconf_copy_file (const char *dst, const char *src);
+
+ #define strcaseeq(s1, s2) (g_strcasecmp ((s1), (s2)) == 0)
+ #define strncaseeq(s1, s2, n) (g_strncasecmp ((s1), (s2), (n)) == 0)
+diff -Naur wmakerconf-2.12.orig/src/rootmenu.c wmakerconf-2.12/src/rootmenu.c
+--- wmakerconf-2.12.orig/src/rootmenu.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/rootmenu.c 2012-02-10 17:35:03.929287391 +0100
+@@ -365,7 +365,7 @@
+ node_freeitem, NULL);
+ g_node_destroy (node);
+
+- if (WMWritePropListToFile (menu, filename, YES))
++ if (WMWritePropListToFile(menu, filename))
+ {
+ menu_changed = NO;
+ message (_("Window Maker root menu file '%s' saved."), filename);
+diff -Naur wmakerconf-2.12.orig/src/themebrowser.c wmakerconf-2.12/src/themebrowser.c
+--- wmakerconf-2.12.orig/src/themebrowser.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/themebrowser.c 2012-02-10 17:35:56.515722786 +0100
+@@ -2650,7 +2650,7 @@
+
+ if (path)
+ {
+- if (copy_file (filename, path))
++ if (wmconf_copy_file (filename, path))
+ {
+ Free (filename);
+ Free (path);
+@@ -2705,7 +2705,7 @@
+ oldfiles = g_list_remove (oldfiles, tmp);
+ Free (tmp);
+ }
+- if (!WMWritePropListToFile (theme, stylename, YES))
++ if (!WMWritePropListToFile(theme, stylename))
+ {
+ dialog_popup (DIALOG_ERROR, NULL, NULL,
+ _("Can't save theme file\n`%s'\n"
+@@ -3351,7 +3351,7 @@
+ else
+ #endif /* TAR */
+ {
+- if (copy_file (themedir, unpacked_filename))
++ if (wmconf_copy_file (themedir, unpacked_filename))
+ {
+ continue;
+ }
+diff -Naur wmakerconf-2.12.orig/src/window.c wmakerconf-2.12/src/window.c
+--- wmakerconf-2.12.orig/src/window.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/window.c 2012-02-10 17:35:03.953286677 +0100
+@@ -1069,7 +1069,7 @@
+ WMReleasePropList (all_keys);
+ }
+
+- if (WMWritePropListToFile (newwm, orig_wmaker_fname, YES))
++ if (WMWritePropListToFile(newwm, orig_wmaker_fname))
+ {
+ changed = NO;
+ message (_("Window Maker config file '%s' saved."),
+diff -Naur wmakerconf-2.12.orig/src/wmconfig.c wmakerconf-2.12/src/wmconfig.c
+--- wmakerconf-2.12.orig/src/wmconfig.c 2012-02-10 17:34:57.601475631 +0100
++++ wmakerconf-2.12/src/wmconfig.c 2012-02-10 17:35:03.957286559 +0100
+@@ -216,7 +216,7 @@
+ /*
+ * Generate backup file "'path'.bak"
+ */
+- if (WMWritePropListToFile (orig_rootmenu, new, YES))
++ if (WMWritePropListToFile(orig_rootmenu, new))
+ message (_("Backupfile `%s' generated."), new);
+ else
+ error (_("Can't write backupfile `%s'."), new);
+@@ -280,7 +280,7 @@
+ if (!windowmaker)
+ {
+ windowmaker = global_windowmaker;
+- if (WMWritePropListToFile (windowmaker, orig_wmaker_fname, YES))
++ if (WMWritePropListToFile(windowmaker, orig_wmaker_fname))
+ warning (_("New WindowMaker configuration file `%s' created."),
+ orig_wmaker_fname);
+ else
+@@ -294,7 +294,7 @@
+ /*
+ * Generate backup file "'path'.bak"
+ */
+- if (WMWritePropListToFile (windowmaker, new, YES))
++ if (WMWritePropListToFile(windowmaker, new))
+ message (_("Backupfile `%s' generated."), new);
+ else
+ error (_("Can't write backupfile `%s'."), new);
diff --git a/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild b/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild
new file mode 100644
index 000000000000..694113e74f6a
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.12-r1.ebuild,v 1.1 2012/02/10 18:28:36 voyageur Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+HOMEPAGE="http://wmakerconf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="imlib nls perl"
+
+RDEPEND="x11-libs/gtk+:2
+ >=x11-wm/windowmaker-0.95.0
+ imlib? ( media-libs/imlib )
+ perl? ( dev-lang/perl
+ dev-perl/HTML-Parser
+ dev-perl/libwww-perl
+ www-client/lynx
+ net-misc/wget )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wmaker-0.95_support.patch
+}
+
+src_configure() {
+ local myconf
+ use imlib || myconf="--disable-imlibtest"
+
+ econf \
+ $(use_enable perl upgrade) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" gnulocaledir="${ED}/usr/share/locale" install
+ dodoc AUTHORS ChangeLog MANUAL NEWS README TODO
+ doman man/*.1
+
+ rm -f "${ED}"/usr/share/${PN}/{AUTHORS,README,COPYING,NEWS,MANUAL,ABOUT-NLS,NLS-TEAM1,ChangeLog}
+}
+
+pkg_postinst() {
+ elog "New features added with WindowMaker >= 0.95 will not be available in wmakerconf"
+ elog "WPrefs is the recommended configuration tool"
+}
diff --git a/x11-misc/wmakerconf/wmakerconf-2.12.ebuild b/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
index da9f620b29a7..db9e13ddc8d3 100644
--- a/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
+++ b/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.12.ebuild,v 1.5 2011/03/22 19:31:10 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.12.ebuild,v 1.6 2012/02/10 18:28:36 voyageur Exp $
EAPI=3
@@ -14,7 +14,7 @@ KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="imlib nls perl"
RDEPEND="x11-libs/gtk+:2
- >=x11-wm/windowmaker-0.90.0
+ <x11-wm/windowmaker-0.95.0
imlib? ( media-libs/imlib )
perl? ( dev-lang/perl
dev-perl/HTML-Parser