summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-12-20 22:36:45 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-12-20 22:36:45 +0000
commit4ae0e678c5bd81af47e393fdf1fe29f29d32feba (patch)
treee58520e91b3fee4ecb35b5d92ebb43be25ebef79 /x11-misc/tint2
parentDon't build for Ruby 1.9 since this is incompatible with the test-unit gem. D... (diff)
downloadgentoo-2-4ae0e678c5bd81af47e393fdf1fe29f29d32feba.tar.gz
gentoo-2-4ae0e678c5bd81af47e393fdf1fe29f29d32feba.tar.bz2
gentoo-2-4ae0e678c5bd81af47e393fdf1fe29f29d32feba.zip
Version bump to 0.8.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/tint2')
-rw-r--r--x11-misc/tint2/ChangeLog7
-rw-r--r--x11-misc/tint2/tint2-0.8.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-misc/tint2/ChangeLog b/x11-misc/tint2/ChangeLog
index e7aac9cab973..08b8ec6b76db 100644
--- a/x11-misc/tint2/ChangeLog
+++ b/x11-misc/tint2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/tint2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tint2/ChangeLog,v 1.8 2009/12/14 17:18:04 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tint2/ChangeLog,v 1.9 2009/12/20 22:36:45 idl0r Exp $
+
+*tint2-0.8 (20 Dec 2009)
+
+ 20 Dec 2009; Christian Ruppert <idl0r@gentoo.org> +tint2-0.8.ebuild:
+ Version bump to 0.8.
*tint2-0.7.1-r1 (14 Dec 2009)
diff --git a/x11-misc/tint2/tint2-0.8.ebuild b/x11-misc/tint2/tint2-0.8.ebuild
new file mode 100644
index 000000000000..0de894597805
--- /dev/null
+++ b/x11-misc/tint2/tint2-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tint2/tint2-0.8.ebuild,v 1.1 2009/12/20 22:36:45 idl0r Exp $
+
+EAPI="2"
+
+DESCRIPTION="A lightweight panel/taskbar"
+HOMEPAGE="http://code.google.com/p/tint2/"
+SRC_URI="http://tint2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="battery examples"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/libX11
+ x11-libs/libXinerama
+ media-libs/imlib2[X]"
+# autoconf >= 2.61 for --docdir, bug 296890
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xineramaproto
+ >=sys-devel/autoconf-2.61"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} \
+ $(use_enable battery) \
+ $(use_enable examples)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}