summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-08 12:04:43 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-08 12:04:43 +0000
commit5b07a7096b6cf901030c040b494c22904adf3a98 (patch)
tree9152432370fd2c90bf1878106bbea306414c8049 /x11-misc/sddm
parentStable for x86, wrt bug #503570 (diff)
downloadgentoo-2-5b07a7096b6cf901030c040b494c22904adf3a98.tar.gz
gentoo-2-5b07a7096b6cf901030c040b494c22904adf3a98.tar.bz2
gentoo-2-5b07a7096b6cf901030c040b494c22904adf3a98.zip
Version bump. Fixes bug #534262
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-misc/sddm')
-rw-r--r--x11-misc/sddm/ChangeLog10
-rw-r--r--x11-misc/sddm/files/sddm-0.11.0-consolekit.patch11
-rw-r--r--x11-misc/sddm/sddm-0.11.0.ebuild71
3 files changed, 90 insertions, 2 deletions
diff --git a/x11-misc/sddm/ChangeLog b/x11-misc/sddm/ChangeLog
index cece85b2169f..8356ef042eb5 100644
--- a/x11-misc/sddm/ChangeLog
+++ b/x11-misc/sddm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/sddm
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/ChangeLog,v 1.14 2014/10/18 17:53:57 jauhien Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/ChangeLog,v 1.15 2015/01/08 12:04:43 mrueg Exp $
+
+*sddm-0.11.0 (08 Jan 2015)
+
+ 08 Jan 2015; Manuel Rüger <mrueg@gentoo.org>
+ +files/sddm-0.11.0-consolekit.patch, +sddm-0.11.0.ebuild:
+ Version bump. Fixes bug #534262
18 Oct 2014; Jauhien Piatlicki <jauhien@gentoo.org>
-files/sddm-0.9.0-consolekit.patch, -files/sddm-0.9.0-upower.patch,
diff --git a/x11-misc/sddm/files/sddm-0.11.0-consolekit.patch b/x11-misc/sddm/files/sddm-0.11.0-consolekit.patch
new file mode 100644
index 000000000000..4871bee0f06e
--- /dev/null
+++ b/x11-misc/sddm/files/sddm-0.11.0-consolekit.patch
@@ -0,0 +1,11 @@
+--- data/scripts/Xsession.old 2015-01-08 12:58:24.448241484 +0100
++++ data/scripts/Xsession 2015-01-08 13:00:07.794244087 +0100
+@@ -93,7 +93,7 @@
+ exec xterm -geometry 80x24-0-0
+ ;;
+ *)
+- eval exec "$session"
++ eval exec ck-launch-session "$session"
+ ;;
+ esac
+ exec xmessage -center -buttons OK:0 -default OK "Sorry, cannot execute $session. Check $DESKTOP_SESSION.desktop."
diff --git a/x11-misc/sddm/sddm-0.11.0.ebuild b/x11-misc/sddm/sddm-0.11.0.ebuild
new file mode 100644
index 000000000000..8ce2556f0dc7
--- /dev/null
+++ b/x11-misc/sddm/sddm-0.11.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/sddm-0.11.0.ebuild,v 1.1 2015/01/08 12:04:43 mrueg Exp $
+
+EAPI=5
+inherit cmake-utils toolchain-funcs user
+
+DESCRIPTION="Simple Desktop Display Manager"
+HOMEPAGE="https://github.com/sddm/sddm"
+SRC_URI="http://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2+ MIT CC-BY-3.0 public-domain"
+SLOT="0"
+IUSE="consolekit systemd +upower"
+REQUIRED_USE="?? ( upower systemd )"
+
+RDEPEND="sys-libs/pam
+ >=x11-base/xorg-server-1.15.1
+ x11-libs/libxcb[xkb(-)]
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/linguist-tools:5
+ dev-qt/qttest:5
+ systemd? ( sys-apps/systemd:= )
+ upower? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.7.0
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-version) < 4.7 ]] && \
+ die 'The active compiler needs to be gcc 4.7 (or newer)'
+ fi
+}
+
+src_prepare() {
+ use consolekit && epatch "${FILESDIR}/${P}-consolekit.patch"
+ use upower && epatch "${FILESDIR}/${PN}-0.10.0-upower.patch"
+
+ # respect user's cflags
+ sed -e 's|-Wall -march=native||' \
+ -e 's|-O2||' \
+ -i CMakeLists.txt || die 'sed failed'
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_no systemd SYSTEMD)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use consolekit; then
+ ewarn "This display manager doesn't have native built-in ConsoleKit support."
+ ewarn "In order to use ConsoleKit pam module with this display manager,"
+ ewarn "you should remove the \"nox11\" parameter from pm_ck_connector.so"
+ ewarn "line in /etc/pam.d/system-login"
+ fi
+ ewarn "Add the sddm user manually to the video group"
+ ewarn "if you experience flickering or other rendering issues of sddm-greeter"
+ ewarn "see https://github.com/gentoo/qt/pull/52"
+}
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/sddm ${PN}
+}