summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-01-26 17:53:52 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-01-26 17:53:52 +0000
commit5a2c63ee55731db36dd6d1cd9140d2825417b929 (patch)
treed35c913e118c412ddd6b9652723e791be4862e21 /x11-misc/rednotebook
parentremove bashisms from scripts, install scripts executable (diff)
downloadgentoo-2-5a2c63ee55731db36dd6d1cd9140d2825417b929.tar.gz
gentoo-2-5a2c63ee55731db36dd6d1cd9140d2825417b929.tar.bz2
gentoo-2-5a2c63ee55731db36dd6d1cd9140d2825417b929.zip
Version bump
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog7
-rw-r--r--x11-misc/rednotebook/rednotebook-1.6.6.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 236740f218b2..6fad73094f0b 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.67 2013/01/14 21:34:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.68 2013/01/26 17:53:52 hwoarang Exp $
+
+*rednotebook-1.6.6 (26 Jan 2013)
+
+ 26 Jan 2013; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.6.6.ebuild:
+ Version bump
*rednotebook-1.6.5 (14 Jan 2013)
diff --git a/x11-misc/rednotebook/rednotebook-1.6.6.ebuild b/x11-misc/rednotebook/rednotebook-1.6.6.ebuild
new file mode 100644
index 000000000000..b3f7239969f8
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.6.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.6.6.ebuild,v 1.1 2013/01/26 17:53:52 hwoarang Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2:2.6"
+
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/chardet
+ spell? ( dev-python/gtkspell-python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${PN}-1.6.5-disable-spell.patch"
+ distutils_src_prepare
+}