summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-12-30 13:04:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-12-30 13:04:32 +0000
commit37b8a5250ec00c1deeb68d581c6e1394fbf21214 (patch)
treeae4a6ab83fcc0125bf55e4efae2ee1b111293c30 /x11-misc/rednotebook
parentbump libxtract dep for bug #349930 (diff)
downloadgentoo-2-37b8a5250ec00c1deeb68d581c6e1394fbf21214.tar.gz
gentoo-2-37b8a5250ec00c1deeb68d581c6e1394fbf21214.tar.bz2
gentoo-2-37b8a5250ec00c1deeb68d581c6e1394fbf21214.zip
Version bump
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog8
-rw-r--r--x11-misc/rednotebook/files/rednotebook-1.1.2-disable-webkit.patch16
-rw-r--r--x11-misc/rednotebook/rednotebook-1.1.2.ebuild32
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 0c9aad6a98fa..43ec4cc96737 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.42 2010/10/31 23:19:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.43 2010/12/30 13:04:32 hwoarang Exp $
+
+*rednotebook-1.1.2 (30 Dec 2010)
+
+ 30 Dec 2010; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.1.2.ebuild,
+ +files/rednotebook-1.1.2-disable-webkit.patch:
+ Version bump
31 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
-files/rednotebook-0.8.9_disable_spell.patch,
diff --git a/x11-misc/rednotebook/files/rednotebook-1.1.2-disable-webkit.patch b/x11-misc/rednotebook/files/rednotebook-1.1.2-disable-webkit.patch
new file mode 100644
index 000000000000..d07d8d183275
--- /dev/null
+++ b/x11-misc/rednotebook/files/rednotebook-1.1.2-disable-webkit.patch
@@ -0,0 +1,16 @@
+Index: rednotebook-1.1.2/rednotebook/gui/browser.py
+===================================================================
+--- rednotebook-1.1.2.orig/rednotebook/gui/browser.py
++++ rednotebook-1.1.2/rednotebook/gui/browser.py
+@@ -40,11 +40,6 @@ from rednotebook.util import filesystem
+
+
+ webkit = None
+-try:
+- import webkit
+-except ImportError:
+- logging.info('webkit not found. For a nicer preview install python-webkit or pywebkitgtk')
+-
+
+
+ def can_print_pdf():
diff --git a/x11-misc/rednotebook/rednotebook-1.1.2.ebuild b/x11-misc/rednotebook/rednotebook-1.1.2.ebuild
new file mode 100644
index 000000000000..32b0aab1c549
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.1.2.ebuild,v 1.1 2010/12/30 13:04:32 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${P}-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-1.1.0-disable-spell.patch"
+ distutils_src_prepare
+}