summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-12-17 14:06:40 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-12-17 14:06:40 +0000
commit75d5b5446fe40ab7c23da260728dd63ae7ebb277 (patch)
tree5b69649e3650d09a695998ace89a61a0c25efb46 /x11-misc/pogo
parentInitial import of pogo, launcher program for X (diff)
downloadgentoo-2-75d5b5446fe40ab7c23da260728dd63ae7ebb277.tar.gz
gentoo-2-75d5b5446fe40ab7c23da260728dd63ae7ebb277.tar.bz2
gentoo-2-75d5b5446fe40ab7c23da260728dd63ae7ebb277.zip
Initial import of pogo, launcher program for X
Diffstat (limited to 'x11-misc/pogo')
-rw-r--r--x11-misc/pogo/ChangeLog11
-rw-r--r--x11-misc/pogo/Manifest4
-rw-r--r--x11-misc/pogo/files/Makefile26
-rw-r--r--x11-misc/pogo/files/digest-pogo-2.21
-rw-r--r--x11-misc/pogo/pogo-2.2.ebuild32
5 files changed, 73 insertions, 1 deletions
diff --git a/x11-misc/pogo/ChangeLog b/x11-misc/pogo/ChangeLog
new file mode 100644
index 000000000000..32f243f7b68c
--- /dev/null
+++ b/x11-misc/pogo/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/pogo
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pogo/ChangeLog,v 1.1 2003/12/17 14:06:22 lostlogic Exp $
+
+*pogo-2.2 (17 Dec 2003)
+
+ 17 Dec 2003; Brandon Low <lostlogic@gentoo.org> pogo-2.2.ebuild,
+ files/Makefile:
+ Initial import, pogo is a launcher program for X, it is very configurable, and
+ generally should work under any window manager
+
diff --git a/x11-misc/pogo/Manifest b/x11-misc/pogo/Manifest
index ccae263df7ea..313881d40f07 100644
--- a/x11-misc/pogo/Manifest
+++ b/x11-misc/pogo/Manifest
@@ -1,2 +1,4 @@
-MD5 6d98b5bdbbcc0a7274f4b5eec24aad78 pogo-2.2.ebuild 652
+MD5 6e1c60e122653c19a685415269ca492b pogo-2.2.ebuild 848
+MD5 55f013e009a7dbd716d5315879535105 ChangeLog 452
+MD5 7866986b7b75f93f57b2704e24c21f49 files/Makefile 787
MD5 14dfeacc336e0247acb2541756227083 files/digest-pogo-2.2 60
diff --git a/x11-misc/pogo/files/Makefile b/x11-misc/pogo/files/Makefile
new file mode 100644
index 000000000000..55bfd3e5e0cb
--- /dev/null
+++ b/x11-misc/pogo/files/Makefile
@@ -0,0 +1,26 @@
+all: pogo pogo-remote
+
+pogo: pogo.c
+ gcc ${CFLAGS} -o pogo pogo.c -Wall -I/usr/X11R6/include -I${DESTDIR}/usr/share/include -L/usr/X11R6/lib -L${DESTDIR}/usr/share/lib -lX11 -lXext -ljpeg -lz -lm -lImlib
+
+pogo-remote: pogo-remote.c
+ gcc ${CFLAGS} -o pogo-remote pogo-remote.c -Wall
+
+install:
+ mkdir -p ${DESTDIR}/usr/bin
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2/images
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2/scripts
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2/configs
+
+ cp images/*.jpg ${DESTDIR}/usr/share/pogo-2.2/images/
+ cp scripts/*.pogo ${DESTDIR}/usr/share/pogo-2.2/scripts/
+ cp configs/*.config ${DESTDIR}/usr/share/pogo-2.2/configs/
+
+ cp pogo ${DESTDIR}/usr/bin/
+ cp pogo-remote ${DESTDIR}/usr/bin
+
+clean:
+ rm -rf pogo
+ rm -rf pogo-remote
+
diff --git a/x11-misc/pogo/files/digest-pogo-2.2 b/x11-misc/pogo/files/digest-pogo-2.2
new file mode 100644
index 000000000000..e4340ea60e04
--- /dev/null
+++ b/x11-misc/pogo/files/digest-pogo-2.2
@@ -0,0 +1 @@
+MD5 366d3122e768b17cd9bdc0e236df3c79 pogo-2.2.tar.gz 834903
diff --git a/x11-misc/pogo/pogo-2.2.ebuild b/x11-misc/pogo/pogo-2.2.ebuild
new file mode 100644
index 000000000000..1ee112e094c1
--- /dev/null
+++ b/x11-misc/pogo/pogo-2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pogo/pogo-2.2.ebuild,v 1.1 2003/12/17 14:06:22 lostlogic Exp $
+
+S="${WORKDIR}/Epplets-${PV}"
+
+DESCRIPTION="Pogo is a neat launcher program for X"
+SRC_URI="http://www.ibiblio.org/propaganda/${PN}/${P}.tar.gz"
+
+HOMEPAGE="http://www.ibiblio.org/propaganda/pogo/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+S=${WORKDIR}/${P}
+
+DEPEND="virtual/x11
+ media-libs/imlib
+ media-libs/jpeg"
+
+src_compile() {
+ cp ${FILESDIR}/Makefile .
+ make clean || die "Clean failed"
+ for file in `grep -r /usr/local/ *|cut -f1 -d":"|sort|uniq`;do
+ sed -i -e "s:/usr/local:/usr/share:g" ${file}
+ done
+ make all || "Make failed"
+}
+
+src_install () {
+ dodoc README
+ make DESTDIR="${D}" install || die "Install failed"
+}