summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-07-12 19:38:02 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-07-12 19:38:02 +0000
commitc06a5d8b5509f46b12ebe1d02aed3d7c5c2cca9a (patch)
treebfd56cbe721a5c6bd7ca6a8bc15eb63de5fd0642 /x11-misc/numlockx
parentAdded HL-1250 support for real this time. (diff)
downloadgentoo-2-c06a5d8b5509f46b12ebe1d02aed3d7c5c2cca9a.tar.gz
gentoo-2-c06a5d8b5509f46b12ebe1d02aed3d7c5c2cca9a.tar.bz2
gentoo-2-c06a5d8b5509f46b12ebe1d02aed3d7c5c2cca9a.zip
Initial version. Closes #4110.
Diffstat (limited to 'x11-misc/numlockx')
-rw-r--r--x11-misc/numlockx/ChangeLog10
-rw-r--r--x11-misc/numlockx/files/digest-numlockx-1.01
-rw-r--r--x11-misc/numlockx/numlockx-1.0.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/numlockx/ChangeLog b/x11-misc/numlockx/ChangeLog
new file mode 100644
index 000000000000..f2aa06a3167c
--- /dev/null
+++ b/x11-misc/numlockx/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/numlockx
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/numlockx/ChangeLog,v 1.1 2002/07/12 19:38:02 agenkin Exp $
+
+*numlockx-1.0 (12 Jul 2002)
+
+ 12 Jul 2002; Arcady Genkin <agenkin@thpoon.com> numlockx-1.0.ebuild:
+
+ First version, thanks to Jacob Perkins <jap1@ionet.net> and
+ Johannes Findeisen <you@hanez.org>. \ No newline at end of file
diff --git a/x11-misc/numlockx/files/digest-numlockx-1.0 b/x11-misc/numlockx/files/digest-numlockx-1.0
new file mode 100644
index 000000000000..f6334146155e
--- /dev/null
+++ b/x11-misc/numlockx/files/digest-numlockx-1.0
@@ -0,0 +1 @@
+MD5 e6956c130f29d0099291281dc99f049b numlockx-1.0.tar.gz 34936
diff --git a/x11-misc/numlockx/numlockx-1.0.ebuild b/x11-misc/numlockx/numlockx-1.0.ebuild
new file mode 100644
index 000000000000..68c98f54caf7
--- /dev/null
+++ b/x11-misc/numlockx/numlockx-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/numlockx/numlockx-1.0.ebuild,v 1.1 2002/07/12 19:38:02 agenkin Exp $
+
+DESCRIPTION="Turns on numlock in X"
+
+HOMEPAGE="http://dforce.sh.cvut.cz/~seli/en/numlockx"
+LICENSE="EDB"
+
+DEPEND="virtual/x11"
+
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+src_compile(){
+ ./configure \
+ --prefix=/usr/X11R6 \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install(){
+ dodoc AUTHORS INSTALL LICENSE README
+
+ into /usr/X11R6
+ dobin numlockx
+}
+
+pkg_postinst(){
+ einfo ""
+ einfo "add 'numlockx' to your X startup programs to have numlock turn on when X starts"
+ einfo ""
+}