summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-06 12:50:22 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-06 12:50:22 +0000
commit57fe1d149fa1c329cc42739214a847ca134745f9 (patch)
tree604e6a7d4a418624fa67fd0d38184cb8fc5cfe64 /x11-misc/idesk-extras
parentversion bump (diff)
downloadgentoo-2-57fe1d149fa1c329cc42739214a847ca134745f9.tar.gz
gentoo-2-57fe1d149fa1c329cc42739214a847ca134745f9.tar.bz2
gentoo-2-57fe1d149fa1c329cc42739214a847ca134745f9.zip
revbump (patch: fix stderr mess)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc/idesk-extras')
-rw-r--r--x11-misc/idesk-extras/ChangeLog10
-rw-r--r--x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch112
-rw-r--r--x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild33
3 files changed, 153 insertions, 2 deletions
diff --git a/x11-misc/idesk-extras/ChangeLog b/x11-misc/idesk-extras/ChangeLog
index 1a4fce23abca..dd2b7e586c7e 100644
--- a/x11-misc/idesk-extras/ChangeLog
+++ b/x11-misc/idesk-extras/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/idesk-extras
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk-extras/ChangeLog,v 1.3 2012/06/20 19:04:15 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk-extras/ChangeLog,v 1.4 2013/10/06 12:50:21 hasufell Exp $
+
+*idesk-extras-1.37-r1 (06 Oct 2013)
+
+ 06 Oct 2013; Julian Ospald <hasufell@gentoo.org>
+ +idesk-extras-1.37-r1.ebuild, +files/idesk-extras-1.37-stdout.patch:
+ revbump (patch: fix stderr mess)
20 Jun 2012; Agostino Sarubbo <ago@gentoo.org> idesk-extras-1.37.ebuild:
Stable for amd64, wrt bug #422475
diff --git a/x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch b/x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch
new file mode 100644
index 000000000000..d827184ff9a4
--- /dev/null
+++ b/x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch
@@ -0,0 +1,112 @@
+From b8e096f75c9a2fb3a5f02146f0e52ccae796aa87 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 14:39:02 +0200
+Subject: [PATCH] use stdout to avoid broken tmp files
+
+e.g. fontconfig errors will break parsing
+---
+ idesktool | 28 ++++++++++++++--------------
+ 1 file changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/idesktool b/idesktool
+index 931ad6f..90e5ceb 100755
+--- a/idesktool
++++ b/idesktool
+@@ -88,10 +88,10 @@ end" > ~/.ideskrc
+ newcaption()
+ {
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --inputbox "Icon Caption:\n
+ (Leave blank for no caption)"\
+- 8 40 "$cap" 2> ~/.idesktop/inputbox.tmp.$$
++ 8 40 "$cap" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+ case $retval in
+ 0) cap=$(cat ~/.idesktop/inputbox.tmp.$$)
+@@ -132,10 +132,10 @@ modcaption=NoCaption$$
+ fi
+
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --separate-output --2inputsbox "NOTE: The default right-click command \n
+ runs this configuration tool (recommended)."\
+- 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 2> ~/.idesktop/inputbox.tmp.$$
++ 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+
+ case $retval in
+@@ -187,10 +187,10 @@ modifycaption()
+
+ {
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --inputbox "Icon Caption:\n
+ (Leave blank for no caption)"\
+- 8 40 "$currentcaption" 2> ~/.idesktop/inputbox.tmp.$$
++ 8 40 "$currentcaption" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+ case $retval in
+ 0) cap=$(cat ~/.idesktop/inputbox.tmp.$$)
+@@ -235,10 +235,10 @@ modcaption=NoCaption$$
+ fi
+
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --separate-output --2inputsbox "NOTE: The default right-click command \n
+ runs this configuration tool (recommended)."\
+- 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 2> ~/.idesktop/inputbox.tmp.$$
++ 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+ case $retval in
+ 1) rm -f ~/.idesktop/inputbox.tmp.$$
+@@ -423,13 +423,13 @@ argyyep()
+
+ firstwindow=argyyep
+
+-$DIALOG --title "idesktool 1.36" \
++$DIALOG --stdout --title "idesktool 1.36" \
+ --radiolist "Desktop Icon Manager" 18 40 0 \
+ "Properties" "View or Edit This Icon" off \
+ "Delete" " Remove This Icon" off \
+ "New" " Add a New Icon" off \
+ "Refresh" " Reload the Desktop" off \
+- "Configure" " Edit iDesk's conf. file" off 2> ~/.idesktop/checklist.tmp.$$
++ "Configure" " Edit iDesk's conf. file" off 1> ~/.idesktop/checklist.tmp.$$
+
+ retval=$?
+
+@@ -469,13 +469,13 @@ argynope()
+
+ firstwindow=argynope
+
+-$DIALOG --title "idesktool 1.36" \
++$DIALOG --stdout --title "idesktool 1.36" \
+ --radiolist "Desktop Icon Manager" 18 40 0 \
+ "Properties" "View or Edit an Icon" off \
+ "Delete" " Remove an Icon" off \
+ "New" " Add a new Icon" off \
+ "Refresh" " Reload the Desktop" off \
+- "Configure" " Edit iDesk's conf. file" off 2> ~/.idesktop/checklist.tmp.$$
++ "Configure" " Edit iDesk's conf. file" off 1> ~/.idesktop/checklist.tmp.$$
+ retval=$?
+
+ case $retval in
+@@ -511,8 +511,8 @@ esac
+ ##########################################################
+ editconfig()
+ {
+-Xdialog --title "iDesk Configuration" --fixed-font "" \
+- --editbox ~/.ideskrc 0 0 2> ~/.idesktop/editbox.txt.$$
++Xdialog --stdout --title "iDesk Configuration" --fixed-font "" \
++ --editbox ~/.ideskrc 0 0 1> ~/.idesktop/editbox.txt.$$
+
+ case $? in
+ 0) cat ~/.idesktop/editbox.txt.$$ > ~/.ideskrc
+--
+1.8.3.2
+
diff --git a/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild b/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild
new file mode 100644
index 000000000000..1acfeda5e793
--- /dev/null
+++ b/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild,v 1.1 2013/10/06 12:50:21 hasufell Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Graphical configuration for iDesk plus icons"
+HOMEPAGE="http://www.jmurray.id.au/idesk-extras.html" # dead?
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ x11-misc/idesk
+ x11-misc/xdialog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-stdout.patch
+}
+
+src_install() {
+ dobin idesktool
+ dodoc CHANGES
+ dohtml ${PN}.html
+
+ insinto /usr/share/idesk
+ doins -r icons
+}