summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2007-10-31 16:52:30 +0000
committerFerris McCormick <fmccor@gentoo.org>2007-10-31 16:52:30 +0000
commit4ce9399aec6a0e4ad90fddb810567a4f10b933f1 (patch)
tree83d6b7874e6547dd3d9110a851985e380b17dacd /x11-misc/afbinit
parentStable for HPPA (bug #197313). (diff)
downloadgentoo-2-4ce9399aec6a0e4ad90fddb810567a4f10b933f1.tar.gz
gentoo-2-4ce9399aec6a0e4ad90fddb810567a4f10b933f1.tar.bz2
gentoo-2-4ce9399aec6a0e4ad90fddb810567a4f10b933f1.zip
Version bump for change in dmesg format to report FFB devices.
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-misc/afbinit')
-rw-r--r--x11-misc/afbinit/ChangeLog8
-rw-r--r--x11-misc/afbinit/afbinit-1.0.1-r6.ebuild45
-rw-r--r--x11-misc/afbinit/files/digest-afbinit-1.0.1-r63
-rw-r--r--x11-misc/afbinit/files/rc.afb-1.0.1-r6.patch60
4 files changed, 115 insertions, 1 deletions
diff --git a/x11-misc/afbinit/ChangeLog b/x11-misc/afbinit/ChangeLog
index 9ef1f50f5c55..8d878fb88b2e 100644
--- a/x11-misc/afbinit/ChangeLog
+++ b/x11-misc/afbinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/afbinit
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/afbinit/ChangeLog,v 1.21 2007/04/28 21:53:45 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/afbinit/ChangeLog,v 1.22 2007/10/31 16:52:29 fmccor Exp $
+
+*afbinit-1.0.1-r6 (31 Oct 2007)
+
+ 31 Oct 2007; Ferris McCormick <fmccor@gentoo.org>
+ +files/rc.afb-1.0.1-r6.patch, +afbinit-1.0.1-r6.ebuild:
+ Version bump for change in dmesg format to report FFB devices.
28 Apr 2007; Sven Wegener <swegener@gentoo.org> afbinit-1.0.1-r4.ebuild:
Fix *initd, *confd and *envd calls (#173884, #174266)
diff --git a/x11-misc/afbinit/afbinit-1.0.1-r6.ebuild b/x11-misc/afbinit/afbinit-1.0.1-r6.ebuild
new file mode 100644
index 000000000000..4aca98ee0897
--- /dev/null
+++ b/x11-misc/afbinit/afbinit-1.0.1-r6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/afbinit/afbinit-1.0.1-r6.ebuild,v 1.1 2007/10/31 16:52:29 fmccor Exp $
+
+inherit eutils
+
+DESCRIPTION="loads the microcode for Elite3D framebuffers to use X"
+HOMEPAGE="I dont have a home :("
+SRC_URI="http://cvs.gentoo.org/~weeve/files/${P}.tar.bz2"
+IUSE=""
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="-* ~sparc"
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+src_unpack() {
+ unpack ${A}
+ ##
+ # Patch rc.afb to handle both kernels 2.4.x and 2.6.x
+ einfo "Patching to handle both kernel 2.4.x and 2.6.x style afb identification"
+ cd "${S}"
+ epatch "${FILESDIR}"/rc.afb-${PVR}.patch || die "Cannot patch rc.afb init script"
+ einfo 'Patching afbinit.c to use MMAP_PUBLIC (needed for kernels > 2.6.14)'
+ epatch "${FILESDIR}"/afbinit-mmap-${PV}.patch || die "Cannot patch for mmap"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ dosbin afbinit
+ dosbin rc.afb
+ newinitd "${FILESDIR}"/afbinit.init afbinit
+}
+
+pkg_postinst() {
+ einfo "To use afbinit, you'll need the AFB microcode."
+ einfo "This is available via a Solaris install at /usr/lib/afb.ucode"
+ einfo "or via sun.com"
+}
diff --git a/x11-misc/afbinit/files/digest-afbinit-1.0.1-r6 b/x11-misc/afbinit/files/digest-afbinit-1.0.1-r6
new file mode 100644
index 000000000000..2463ee5c7015
--- /dev/null
+++ b/x11-misc/afbinit/files/digest-afbinit-1.0.1-r6
@@ -0,0 +1,3 @@
+MD5 e8fe8ac0fc16d942ff3b1508e8324e6a afbinit-1.0.1.tar.bz2 3288
+RMD160 3b401ce48ad3f135c2548b293df906dc7ddd6068 afbinit-1.0.1.tar.bz2 3288
+SHA256 3a9b246b34f9b518f2e9a143e5c9faacd0197baa4e5dd13f82ce3c336a3c285c afbinit-1.0.1.tar.bz2 3288
diff --git a/x11-misc/afbinit/files/rc.afb-1.0.1-r6.patch b/x11-misc/afbinit/files/rc.afb-1.0.1-r6.patch
new file mode 100644
index 000000000000..d02a0732cea4
--- /dev/null
+++ b/x11-misc/afbinit/files/rc.afb-1.0.1-r6.patch
@@ -0,0 +1,60 @@
+--- rc.afb- 2004-05-27 17:59:23.549406000 +0000
++++ rc.afb 2004-05-27 18:32:34.709406000 +0000
+@@ -10,25 +10,44 @@
+ exit 0
+ fi
+
+-if [ `/bin/dmesg | /bin/grep -c "Elite 3D"` -eq 0 ]
++# The microcode loader binary and the microcode
++# itself must exist.
++if [ ! -x /usr/sbin/afbinit -o ! -f /usr/lib/afb.ucode ]
+ then
+ exit 0
+ fi
+
+-# The microcode loader binary and the microcode
+-# itself must exist.
+-if [ ! -x /usr/sbin/afbinit -o ! -f /usr/lib/afb.ucode ]
++# Make FB device list, depending on which kind of kernel we have.
++# First, try kernel 2.4.x
++
++if [ `/bin/dmesg | /bin/grep -c "Elite 3D"` -gt 0 ]
+ then
++
++ afb_devs=`/bin/dmesg | /bin/egrep -i "Elite 3D" | /bin/sed 's/\:.*//'`
++
++ # Load microcode onto each card.
++ for AFB in ${afb_devs}
++ do
++ echo -n "${AFB}: Loading Elite3D microcode... "
++ /usr/sbin/afbinit /dev/${AFB} /usr/lib/afb.ucode
++ echo "done."
++ done
+ exit 0
+ fi
++##
++# OK, we're not kernel 2.4.x
++# try kernel 2.6.x
+
+-# Make FB device list.
+-afb_devs=`/bin/dmesg | /bin/egrep -i "Elite 3D" | /bin/sed 's/\:.*//'`
++if [ `/bin/dmesg | /bin/grep -c "AFB"` -gt 0 ]
++then
+
+-# Load microcode onto each card.
+-for AFB in ${afb_devs}
+-do
+- echo -n "${AFB}: Loading Elite3D microcode... "
+- /usr/sbin/afbinit /dev/${AFB} /usr/lib/afb.ucode
+- echo "done."
+-done
++ afb_devs=`/bin/more -s /proc/fb | /bin/egrep -i "Elite 3D" | /bin/sed 's/\ .*//'`
++ # Load microcode onto each card.
++ for AFB in ${afb_devs}
++ do
++ echo -n "/dev/fb${AFB}: Loading Elite3D microcode... "
++ /usr/sbin/afbinit /dev/fb${AFB} /usr/lib/afb.ucode
++ echo "done."
++ done
++ exit 0
++fi