summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-19 12:56:13 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-19 12:56:13 +0000
commitcb91ff0bad340464d16f6fba1df7c9b099df6ab4 (patch)
treef1e404c1d6a594f18339126eb284628ac1501d99 /x11-libs
parentOld. (diff)
downloadgentoo-2-cb91ff0bad340464d16f6fba1df7c9b099df6ab4.tar.gz
gentoo-2-cb91ff0bad340464d16f6fba1df7c9b099df6ab4.tar.bz2
gentoo-2-cb91ff0bad340464d16f6fba1df7c9b099df6ab4.zip
x11-libs/qwtpolar: Version Bump
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qwtpolar/ChangeLog7
-rw-r--r--x11-libs/qwtpolar/qwtpolar-1.1.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-libs/qwtpolar/ChangeLog b/x11-libs/qwtpolar/ChangeLog
index 8078f843944a..2ce2bc51fae9 100644
--- a/x11-libs/qwtpolar/ChangeLog
+++ b/x11-libs/qwtpolar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qwtpolar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtpolar/ChangeLog,v 1.8 2014/02/15 11:41:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtpolar/ChangeLog,v 1.9 2014/09/19 12:56:13 jlec Exp $
+
+*qwtpolar-1.1.1 (19 Sep 2014)
+
+ 19 Sep 2014; Justin Lecher <jlec@gentoo.org> +qwtpolar-1.1.1.ebuild:
+ Version Bump
*qwtpolar-1.1.0 (15 Feb 2014)
diff --git a/x11-libs/qwtpolar/qwtpolar-1.1.1.ebuild b/x11-libs/qwtpolar/qwtpolar-1.1.1.ebuild
new file mode 100644
index 000000000000..5a0851342b7b
--- /dev/null
+++ b/x11-libs/qwtpolar/qwtpolar-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtpolar/qwtpolar-1.1.1.ebuild,v 1.1 2014/09/19 12:56:13 jlec Exp $
+
+EAPI=5
+
+inherit multilib qt4-r2
+
+DESCRIPTION="Library for displaying values on a polar coordinate system"
+HOMEPAGE="http://qwtpolar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="qwt"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qwt:6[svg]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed \
+ -e "/QWT_POLAR_INSTALL_PREFIX /s:=.*$:= ${EPREFIX}/usr:g" \
+ -e "/QWT_POLAR_INSTALL_LIBS/s:lib:$(get_libdir):g" \
+ -e "/QWT_POLAR_INSTALL_DOCS/s:doc:share/doc/${PF}:g" \
+ -e "/QWT_POLAR_INSTALL_PLUGINS/s:=.*$:= ${EPREFIX}/usr/$(get_libdir)/qt4/plugins/designer6/:g" \
+ -e "/QWT_POLAR_INSTALL_FEATURES/s:=.*$:= ${EPREFIX}/usr/$(get_libdir)/qt4/plugins/features6/:g" \
+ -e "/= QwtPolarDesigner/ d" \
+ -e "/= QwtPolarExamples/d" \
+ -i ${PN}config.pri || die
+
+ sed \
+ -e "s:{QWT_POLAR_ROOT}/lib:{QWT_POLAR_ROOT}/$(get_libdir):" \
+ -i src/src.pro || die
+ echo "INCLUDEPATH += ${EPREFIX}/usr/include/qwt6" >> src/src.pro
+ cat >> designer/designer.pro <<- EOF
+ INCLUDEPATH += "${EPREFIX}"/usr/include/qwt6
+ LIBS += -L"${S}"/$(get_libdir)
+ EOF
+}