summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-30 00:48:21 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-30 00:48:21 +0000
commit9e1041b5afd1606df6f25fb90d349228f89ce092 (patch)
tree97cf076c51843382dad21196340b5de81781cceb /x11-libs
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-9e1041b5afd1606df6f25fb90d349228f89ce092.tar.gz
gentoo-2-9e1041b5afd1606df6f25fb90d349228f89ce092.tar.bz2
gentoo-2-9e1041b5afd1606df6f25fb90d349228f89ce092.zip
build the opengl graphicssystem - bug 281674
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-opengl/ChangeLog7
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.5.2-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 6ba1bf015153..49c0a4667ddc 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.36 2009/06/30 15:12:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.37 2009/08/30 00:48:21 wired Exp $
+
+*qt-opengl-4.5.2-r1 (30 Aug 2009)
+
+ 30 Aug 2009; Alex Alexander <wired@gentoo.org> +qt-opengl-4.5.2-r1.ebuild:
+ build the opengl graphicssystem - thanks to Davide Pesavento - bug 281674
30 Jun 2009; Raúl Porcel <armin76@gentoo.org> qt-opengl-4.5.1.ebuild:
ia64/sparc stable wrt #266201
diff --git a/x11-libs/qt-opengl/qt-opengl-4.5.2-r1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.5.2-r1.ebuild
new file mode 100644
index 000000000000..022643e60635
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.5.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.5.2-r1.ebuild,v 1.1 2009/08/30 00:48:21 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[debug=,qt3support=]
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/opengl
+src/plugins/graphicssystems/opengl"
+
+QT4_EXTRACT_DIRECTORIES="
+include/QtCore
+include/QtGui
+include/QtOpenGL
+src/corelib
+src/gui
+src/opengl
+src/plugins
+src/3rdparty"
+
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}