summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-05-25 16:37:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-05-25 16:37:01 +0000
commit4de4bbaf8efde4fcabfe5142d46303274c0d8ebd (patch)
tree3673fcf692edec1ef05a304fc1ee7b7633d970ab /x11-libs
parentVersion bump to 2.0_rc46 and closing bug #132180 and bug #128878. (diff)
downloadgentoo-2-4de4bbaf8efde4fcabfe5142d46303274c0d8ebd.tar.gz
gentoo-2-4de4bbaf8efde4fcabfe5142d46303274c0d8ebd.tar.bz2
gentoo-2-4de4bbaf8efde4fcabfe5142d46303274c0d8ebd.zip
Version bump to 4.1.3
(Portage version: 2.1_rc2)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog7
-rw-r--r--x11-libs/qt/files/digest-qt-4.1.26
-rw-r--r--x11-libs/qt/files/digest-qt-4.1.33
-rw-r--r--x11-libs/qt/qt-4.1.3.ebuild201
4 files changed, 213 insertions, 4 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index b6e6dd1978c5..46c6e876ecc0 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.316 2006/05/24 13:11:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.317 2006/05/25 16:37:01 caleb Exp $
+
+*qt-4.1.3 (25 May 2006)
+
+ 25 May 2006; Caleb Tennis <caleb@gentoo.org> +qt-4.1.3.ebuild:
+ Bump for a new version
24 May 2006; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Force digest regen.
diff --git a/x11-libs/qt/files/digest-qt-4.1.2 b/x11-libs/qt/files/digest-qt-4.1.2
index 0c6dcd7f7587..a2523c6c4228 100644
--- a/x11-libs/qt/files/digest-qt-4.1.2
+++ b/x11-libs/qt/files/digest-qt-4.1.2
@@ -1,3 +1,3 @@
-MD5 a3ea127646905301cbd3c5a83d35c791 qt-x11-opensource-src-4.1.2.tar.gz 9453704
-RMD160 4b93173d938269d1b2a9901f562e9b9e7c243ec9 qt-x11-opensource-src-4.1.2.tar.gz 9453704
-SHA256 c66ab1a78ced107a1af92e62351110691f86549f4f62232e3140f930c630ccc1 qt-x11-opensource-src-4.1.2.tar.gz 9453704
+MD5 18bca010d09b98e94210710047baca0a qt-x11-opensource-src-4.1.2.tar.gz 27924277
+RMD160 b4a0031a7c8d72492d8afa1a1190493999cb17ff qt-x11-opensource-src-4.1.2.tar.gz 27924277
+SHA256 025655971eef7f76ece9754346d6eb4e2dd44ddf569c4c84de27836aa24b04a3 qt-x11-opensource-src-4.1.2.tar.gz 27924277
diff --git a/x11-libs/qt/files/digest-qt-4.1.3 b/x11-libs/qt/files/digest-qt-4.1.3
new file mode 100644
index 000000000000..7f09c54afeab
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-4.1.3
@@ -0,0 +1,3 @@
+MD5 c6fc6934bfca458dde6e6370a2ed0101 qt-x11-opensource-src-4.1.3.tar.gz 32200887
+RMD160 ecd103f99b2d1ca4b88e749faee5553b8c1c53e2 qt-x11-opensource-src-4.1.3.tar.gz 32200887
+SHA256 1323af63fcb0b8aef52b90a6a2b81dbe1d7d929ba3ef02209940536c3ec06143 qt-x11-opensource-src-4.1.3.tar.gz 32200887
diff --git a/x11-libs/qt/qt-4.1.3.ebuild b/x11-libs/qt/qt-4.1.3.ebuild
new file mode 100644
index 000000000000..ddf87c09f31b
--- /dev/null
+++ b/x11-libs/qt/qt-4.1.3.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.3.ebuild,v 1.1 2006/05/25 16:37:01 caleb Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SRCTYPE="opensource-src"
+DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework."
+HOMEPAGE="http://www.trolltech.com/"
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.gz"
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
+
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="accessibility cups debug doc examples firebird gif jpeg mng mysql nas nis odbc opengl png postgres sqlite xinerama zlib"
+
+DEPEND="|| ( ( x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXfont
+ x11-libs/libSM
+ x11-proto/xextproto
+ x11-proto/inputproto
+ xinerama? ( x11-proto/xineramaproto x11-libs/libXinerama )
+ )
+ virtual/x11
+ )
+ virtual/xft
+ >=media-libs/freetype-2
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mng? ( media-libs/libmng )
+ nas? ( >=media-libs/nas-1.5 )
+ odbc? ( dev-db/unixODBC )
+ mysql? ( dev-db/mysql )
+ firebird? ( dev-db/firebird )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( dev-db/libpq )
+ cups? ( net-print/cups )
+ zlib? ( sys-libs/zlib )"
+
+pkg_setup() {
+ if has nodoc ${FEATURES}; then
+ eerror "Qt-4 is incompatible with the 'nodoc' feature of portage. Please disable this feature and retry"
+ die
+ fi
+
+ QTBASEDIR=/usr/$(get_libdir)/qt4
+ QTPREFIXDIR=/usr
+ QTBINDIR=/usr/bin
+ QTLIBDIR=/usr/$(get_libdir)/qt4
+ QTPCDIR=/usr/$(get_libdir)/pkgconfig
+ QTDATADIR=/usr/share/qt4
+ QTDOCDIR=/usr/share/doc/${PF}
+ QTHEADERDIR=/usr/include/qt4
+ QTPLUGINDIR=${QTLIBDIR}/plugins
+ QTSYSCONFDIR=/etc/qt4
+ QTTRANSDIR=${QTDATADIR}/translations
+ QTEXAMPLESDIR=${QTDATADIR}/examples
+ QTDEMOSDIR=${QTDATADIR}/demos
+
+ PLATFORM=$(qt_mkspecs_dir)
+}
+
+qt_use() {
+ useq ${1} && echo "-${1}" || echo "-no-${1}"
+ return 0
+}
+
+qt_mkspecs_dir() {
+ # Allows us to define which mkspecs dir we want to use. Currently we only use
+ # linux-g++ or linux-g++-64, but others could be used for various platforms.
+
+ if [[ $(get_libdir) == "lib" ]]; then
+ echo "linux-g++"
+ else
+ echo "linux-g++-64"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e 's:read acceptance:acceptance=yes:' configure
+
+ cd mkspecs/$(qt_mkspecs_dir)
+ # set c/xxflags and ldflags
+
+ # Don't let the user go too overboard with flags. If you really want to, uncomment
+ # out the line below and give 'er a whirl.
+ strip-flags
+ replace-flags -O3 -O2
+
+ sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
+ -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
+ -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
+ qmake.conf
+
+ # Do not link with -rpath. See bug #75181.
+ sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" \
+ qmake.conf
+
+ # Replace X11R6/ directories, so /usr/X11R6/lib -> /usr/lib
+ sed -i -e "s:X11R6/::" qmake.conf
+
+ cd ${S}
+
+ if [[ "$(gcc-major-version)" == "4" ]]; then
+ einfo "Visibility support: auto"
+ else
+ einfo "Visibility support: disabled"
+ sed -i -e "s:CFG_REDUCE_EXPORTS=auto:CFG_REDUCE_EXPORTS=no:" configure
+ fi
+}
+
+src_compile() {
+ export PATH="${S}/bin:${PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ [ $(get_libdir) != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
+
+ myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
+ myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
+ use png && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
+ use jpeg && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
+ use debug && myconf="${myconf} -debug-and-release" || myconf="${myconf} -release"
+ use zlib && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
+
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
+ use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
+ use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
+ use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
+
+ myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
+
+ ./configure -stl -verbose -largefile \
+ -platform ${PLATFORM} -xplatform ${PLATFORM} \
+ -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
+ -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
+ -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} \
+ -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR} ${myconf} || die
+
+ emake sub-tools-all-ordered || die
+ if use examples; then
+ emake sub-examples-all-ordered || die
+ fi
+}
+
+src_install() {
+ export PATH="${S}/bin:${PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ make INSTALL_ROOT=${D} sub-tools-install_subtargets-ordered || die
+
+ if use examples; then
+ make INSTALL_ROOT=${D} sub-examples-install_subtargets || die
+ make INSTALL_ROOT=${D} sub-demos-install_subtargets || die
+ fi
+
+ make INSTALL_ROOT=${D} install_qmake || die
+ make INSTALL_ROOT=${D} install_mkspecs || die
+
+ if use doc; then
+ make INSTALL_ROOT=${D} install_htmldocs || die
+ fi
+
+ # The private header files of QTestLib aren't installed, but are needed by the test library.
+ # This is supposedly fixed in Qt 4.1.1, so this can probably be removed when it is released
+ dodir ${QTHEADERDIR}/QtTest/private
+ cp -pPR ${S}/tools/qtestlib/src/*_p.h ${D}/${QTHEADERDIR}/QtTest/private
+
+ keepdir "${QTSYSCONFDIR}"
+
+ sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.la
+ sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
+ sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.pc
+
+ # Move .pc files into the pkgconfig directory
+ dodir ${QTPCDIR}
+ mv ${D}/${QTLIBDIR}/*.pc ${D}/${QTPCDIR}
+
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:/usr/${libdir}/qt4"
+ done
+
+ cat > "${T}/44qt4" << EOF
+LDPATH=${libdirs:1}
+QMAKESPEC=$(qt_mkspecs_dir)
+EOF
+ doenvd "${T}/44qt4"
+}