summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-05-25 01:32:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-05-25 01:32:17 +0000
commit3015eafc24f74a72fbd8d3ea36c14cddba738c2d (patch)
tree8124497b9a30b496e27d715cd1d9b0234f30d9d2 /x11-libs
parentRevision bump: Don't install npwrapper.so as a plugin, as it is just a placeh... (diff)
downloadgentoo-2-3015eafc24f74a72fbd8d3ea36c14cddba738c2d.tar.gz
gentoo-2-3015eafc24f74a72fbd8d3ea36c14cddba738c2d.tar.bz2
gentoo-2-3015eafc24f74a72fbd8d3ea36c14cddba738c2d.zip
Version bump.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/ChangeLog7
-rw-r--r--x11-libs/goffice/goffice-0.8.15.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index 23d8c79b09da..ec69d1f31cfb 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/goffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.92 2011/04/24 17:35:05 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.93 2011/05/25 01:32:15 eva Exp $
+
+*goffice-0.8.15 (25 May 2011)
+
+ 25 May 2011; Gilles Dartiguelongue <eva@gentoo.org> +goffice-0.8.15.ebuild:
+ Version bump.
24 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> -goffice-0.4.3.ebuild,
-goffice-0.6.6.ebuild:
diff --git a/x11-libs/goffice/goffice-0.8.15.ebuild b/x11-libs/goffice/goffice-0.8.15.ebuild
new file mode 100644
index 000000000000..06cb31840e4a
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.8.15.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.8.15.ebuild,v 1.1 2011/05/25 01:32:17 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="doc gnome"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=gnome-extra/libgsf-1.14.9
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/cairo-1.2[svg]
+ x11-libs/libXext
+ x11-libs/libXrender
+ >=x11-libs/gtk+-2.16:2
+ gnome? ( >=gnome-base/gconf-2:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+ # Gsettings is still experimental
+ if use gnome; then
+ G2CONF="${G2CONF} --with-config-backend=gconf"
+ else
+ G2CONF="${G2CONF} --with-config-backend=keyfile"
+ fi
+
+ G2CONF="${G2CONF}
+ --without-lasem
+ --with-gtk"
+
+ filter-flags -ffast-math
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die
+}