summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-28 02:17:12 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-28 02:17:12 +0000
commit1ca6c504b79812dcae950ed12d59ad9b2d99f6ff (patch)
tree68d47d4a51deef94c0723613701612656ca3463a /x11-libs
parentversion bump (diff)
downloadgentoo-2-1ca6c504b79812dcae950ed12d59ad9b2d99f6ff.tar.gz
gentoo-2-1ca6c504b79812dcae950ed12d59ad9b2d99f6ff.tar.bz2
gentoo-2-1ca6c504b79812dcae950ed12d59ad9b2d99f6ff.zip
now uses fontconfig thanks to azarah
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xft/ChangeLog6
-rw-r--r--x11-libs/xft/xft-2.0.ebuild14
2 files changed, 17 insertions, 3 deletions
diff --git a/x11-libs/xft/ChangeLog b/x11-libs/xft/ChangeLog
index ffe752aae48e..129b38413ba8 100644
--- a/x11-libs/xft/ChangeLog
+++ b/x11-libs/xft/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for x11-libs/xft
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/ChangeLog,v 1.1 2002/10/27 15:19:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/ChangeLog,v 1.2 2002/10/28 02:17:12 foser Exp $
*xft-2.0 (27 Oct 2002)
@@ -8,3 +8,7 @@
Gnome 2.1 commit
This package provides xft2 support, as used by the pango devel series
Usage will probably break a lot of other things
+
+ 28 Oct 2002; foser <foser@gentoo.org> xft-2.0.ebuild :
+ Now properly detects fontconfig.h, which allows for runtime
+ fontaddition/removal. Thanks to Azarah for noticing and fixing.
diff --git a/x11-libs/xft/xft-2.0.ebuild b/x11-libs/xft/xft-2.0.ebuild
index 61a8d307b3de..224b4b9b21eb 100644
--- a/x11-libs/xft/xft-2.0.ebuild
+++ b/x11-libs/xft/xft-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/xft-2.0.ebuild,v 1.1 2002/10/27 15:19:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/xft-2.0.ebuild,v 1.2 2002/10/28 02:17:12 foser Exp $
PROVIDE="virtual/xft"
DESCRIPTION="Xft2"
@@ -10,9 +10,19 @@ LICENSE="fontconfig"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="x11-base/xfree"
+DEPEND="x11-base/xfree
+ >=sys-devel/autoconf-2.53a
+ media-libs/fontconfig"
S="${WORKDIR}/fcpackage.${PV/\./_}/Xft"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ export WANT_AUTOCONF_2_5=1
+ autoconf --force
+}
+
src_compile() {
econf || die "Xft2 config failed"
emake || die "Xft2 make failed"