summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-02-20 23:16:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-02-20 23:16:17 +0000
commit0c2fc9d9147c646eab76e56d7376f385ee6f12c1 (patch)
treea167a3c193d158edb6efbe351bf03204026b438a /x11-libs
parentAdd ~arm-linux keyword. (diff)
downloadgentoo-2-0c2fc9d9147c646eab76e56d7376f385ee6f12c1.tar.gz
gentoo-2-0c2fc9d9147c646eab76e56d7376f385ee6f12c1.tar.bz2
gentoo-2-0c2fc9d9147c646eab76e56d7376f385ee6f12c1.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libwnck/ChangeLog7
-rw-r--r--x11-libs/libwnck/libwnck-3.4.5.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/libwnck/ChangeLog b/x11-libs/libwnck/ChangeLog
index 4128eec19bfe..283bd6c6c3e8 100644
--- a/x11-libs/libwnck/ChangeLog
+++ b/x11-libs/libwnck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libwnck
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.301 2013/02/20 15:57:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.302 2013/02/20 23:16:17 eva Exp $
+
+*libwnck-3.4.5 (20 Feb 2013)
+
+ 20 Feb 2013; Gilles Dartiguelongue <eva@gentoo.org> +libwnck-3.4.5.ebuild:
+ Version bump.
20 Feb 2013; Agostino Sarubbo <ago@gentoo.org> libwnck-3.4.4.ebuild:
Stable for x86, wrt bug #457978
diff --git a/x11-libs/libwnck/libwnck-3.4.5.ebuild b/x11-libs/libwnck/libwnck-3.4.5.ebuild
new file mode 100644
index 000000000000..43f50037c4fa
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-3.4.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/libwnck-3.4.5.ebuild,v 1.1 2013/02/20 23:16:17 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE="+introspection startup-notification tools"
+
+RDEPEND=">=x11-libs/gtk+-3.4:3[introspection?]
+ >=dev-libs/glib-2.32:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14 )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ x86-interix? ( sys-libs/itx-bind )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.6
+ sys-devel/gettext
+ virtual/pkgconfig"
+# eautoreconf needs
+# gnome-base/gnome-common
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ if use x86-interix; then
+ # activate the itx-bind package...
+ append-flags "-I${EPREFIX}/usr/include/bind"
+ append-ldflags "-L${EPREFIX}/usr/lib/bind"
+ fi
+
+ # Don't collide with SLOT=1
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable startup-notification) \
+ $(use_enable tools) \
+ --program-suffix=-${SLOT}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use tools; then
+ elog "wnckprop is now called wnckprop-${SLOT}"
+ elog "wnck-urgency-monitor is now called wnck-urgency-monitor-${SLOT}"
+ fi
+}