summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-10-02 10:13:43 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-10-02 10:13:43 +0000
commitfc7d78e868404563118b24a889e6291e4c307d7c (patch)
tree9d55011d48106621eff814b7399620528fed043e /x11-libs/xview
parentxmms-1.2.10-r6 is ready to go... (diff)
downloadgentoo-2-fc7d78e868404563118b24a889e6291e4c307d7c.tar.gz
gentoo-2-fc7d78e868404563118b24a889e6291e4c307d7c.tar.bz2
gentoo-2-fc7d78e868404563118b24a889e6291e4c307d7c.zip
Bump patches, new ebuild provided by genstef in #gentoo-bugs.
Diffstat (limited to 'x11-libs/xview')
-rw-r--r--x11-libs/xview/ChangeLog7
-rw-r--r--x11-libs/xview/Manifest4
-rw-r--r--x11-libs/xview/files/digest-xview-3.2-r12
-rw-r--r--x11-libs/xview/xview-3.2-r1.ebuild70
4 files changed, 81 insertions, 2 deletions
diff --git a/x11-libs/xview/ChangeLog b/x11-libs/xview/ChangeLog
index 7ef5a1e83ad4..a7df63159101 100644
--- a/x11-libs/xview/ChangeLog
+++ b/x11-libs/xview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xview
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.5 2004/06/24 22:10:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.6 2004/10/02 10:13:43 kloeri Exp $
+
+*xview-3.2-r1 (02 Oct 2004)
+
+ 02 Oct 2004; Bryan Østergaard <kloeri@gentoo.org> +xview-3.2-r1.ebuild:
+ Bump patches, new ebuild provided by genstef in #gentoo-bugs.
11 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> xview-3.2.ebuild:
Stable on alpha.
diff --git a/x11-libs/xview/Manifest b/x11-libs/xview/Manifest
index cc4a45d10eb5..f91ce7960d4b 100644
--- a/x11-libs/xview/Manifest
+++ b/x11-libs/xview/Manifest
@@ -1,4 +1,6 @@
MD5 04c02bf97fbaebbfe9b15f508cea880a xview-3.2.ebuild 2283
-MD5 6c88127b27048e16ea83be329d3ebee7 ChangeLog 701
MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
+MD5 a2d44f764640f9aee9211b286bacc06b xview-3.2-r1.ebuild 2505
+MD5 435ae14a6a388cbd6318316e9c85431d ChangeLog 821
+MD5 48636f5ace70cc3f5033a87188e4e7bf files/digest-xview-3.2-r1 138
MD5 6de3c812dee458777db24502d252984f files/digest-xview-3.2 138
diff --git a/x11-libs/xview/files/digest-xview-3.2-r1 b/x11-libs/xview/files/digest-xview-3.2-r1
new file mode 100644
index 000000000000..289b11ea69f2
--- /dev/null
+++ b/x11-libs/xview/files/digest-xview-3.2-r1
@@ -0,0 +1,2 @@
+MD5 b9ff26d6ad378af320bac45154ceaeba xview-3.2p1.4.src.tar.gz 3227552
+MD5 f9cb7d7fb2b34a24311c9e68c6e1e90d xview_3.2p1.4-18.diff.gz 74196
diff --git a/x11-libs/xview/xview-3.2-r1.ebuild b/x11-libs/xview/xview-3.2-r1.ebuild
new file mode 100644
index 000000000000..0f5a00d398b1
--- /dev/null
+++ b/x11-libs/xview/xview-3.2-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/xview-3.2-r1.ebuild,v 1.1 2004/10/02 10:13:43 kloeri Exp $
+
+inherit eutils
+
+DESCRIPTION="The X Window-System-based Visual/Integrated Environment for Workstations"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/libs/X/xview/"
+
+MY_PN="${P}p1.4"
+
+# This is our compound patch derived from debian. We use it because:
+# * xview is a contribution made to Sun Microsystems (?) to the X community, but
+# fixes for it don't appear to be around other than in the other free distributions.
+# * It does little harm, only some defaults are changed which we can redefine anyway
+SRC_PATCH="${MY_PN/-/_}-18.diff"
+
+# We use the xview tarball available from the X organization, but xfree86 appears
+# to be up and available more often so we use that (it's their primary mirror).
+SRC_URI="http://www.ibiblio.org/pub/Linux/libs/X/xview/${MY_PN}.src.tar.gz
+ mirror://debian/pool/main/x/xview/${SRC_PATCH}.gz"
+S=${WORKDIR}/${MY_PN}
+LICENSE="sun-openlook"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack $A
+ cd $S
+ epatch ../${SRC_PATCH}
+}
+
+src_compile() {
+ # Create the makefile
+ imake -DUseInstalled -I${S}/config -I/usr/X11R6/lib/X11/config \
+ || die "imake failed"
+
+ # This is crazy and I know it, but wait till you read the code in
+ # Build-LinuxXView.bash.
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash libs \
+ || die "building libs failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash clients \
+ || die "building clients failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash contrib \
+ || die "building contrib failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash olvwm \
+ || die "building olvwm failed"
+}
+
+src_install() {
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instlibs \
+ || die "installing libs failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instclients \
+ || die "installing clients failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instcontrib \
+ || die "installing contrib failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instolvwm \
+ || die "installing olvwm failed"
+ cd ${D}/usr
+ ln -s X11R6 openwin
+
+ # The rest of the docs is already installed
+ cd ${S}/doc
+ dodoc README xview-info olgx_api.txt olgx_api.ps sel_api.txt \
+ dnd_api.txt whats_new.ps bugform config/usenixws/paper.ps
+ rm -rf ${D}/usr/X11R6/share/doc/xview && rm -rf ${D}/usr/X11R6/share/doc
+}