summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-03-08 20:06:35 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-03-08 20:06:35 +0000
commit561f7219c3bc7a79c30c931003f6c47e190ea08d (patch)
tree58f405652e504251f682bb5896337f38541a650a /x11-libs/rep-gtk
parentDrop KDE 4.2.0 (diff)
downloadgentoo-2-561f7219c3bc7a79c30c931003f6c47e190ea08d.tar.gz
gentoo-2-561f7219c3bc7a79c30c931003f6c47e190ea08d.tar.bz2
gentoo-2-561f7219c3bc7a79c30c931003f6c47e190ea08d.zip
Version bumps
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/rep-gtk')
-rw-r--r--x11-libs/rep-gtk/ChangeLog11
-rw-r--r--x11-libs/rep-gtk/files/rep-gtk-0.18.4-libdir.patch11
-rw-r--r--x11-libs/rep-gtk/files/rep-gtk-0.18.4-locale.patch11
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.18.4.ebuild39
4 files changed, 70 insertions, 2 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index 502e40ef5d12..e7803a7f1107 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/rep-gtk
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.57 2008/05/17 14:11:56 truedfx Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.58 2009/03/08 20:06:34 truedfx Exp $
+
+*rep-gtk-0.18.4 (05 Mar 2009)
+
+ 05 Mar 2009; Harald van Dijk <truedfx@gentoo.org>
+ +files/rep-gtk-0.18.4-libdir.patch, +files/rep-gtk-0.18.4-locale.patch,
+ +rep-gtk-0.18.4.ebuild:
+ Version bump
17 May 2008; Harald van Dijk <truedfx@gentoo.org> rep-gtk-0.18-r3.ebuild:
Remove pkg-config from RDEPEND (#217278), don't install COPYING
diff --git a/x11-libs/rep-gtk/files/rep-gtk-0.18.4-libdir.patch b/x11-libs/rep-gtk/files/rep-gtk-0.18.4-libdir.patch
new file mode 100644
index 000000000000..388d1d157d7f
--- /dev/null
+++ b/x11-libs/rep-gtk/files/rep-gtk-0.18.4-libdir.patch
@@ -0,0 +1,11 @@
+--- rep-gtk-0.18.4/Makefile.in
++++ rep-gtk-0.18.4/Makefile.in
+@@ -34,7 +34,7 @@
+ DESTDIR=
+ installdir=$(repexecdir)
+
+-libdir=@prefix@/@libdir@
++libdir=@libdir@
+
+ top_srcdir=@top_srcdir@
+ top_builddir=.
diff --git a/x11-libs/rep-gtk/files/rep-gtk-0.18.4-locale.patch b/x11-libs/rep-gtk/files/rep-gtk-0.18.4-locale.patch
new file mode 100644
index 000000000000..515f09b92ce4
--- /dev/null
+++ b/x11-libs/rep-gtk/files/rep-gtk-0.18.4-locale.patch
@@ -0,0 +1,11 @@
+--- rep-gtk-0.18.4/Makefile.in
++++ rep-gtk-0.18.4/Makefile.in
+@@ -51,7 +51,7 @@
+ $(rep_DL_LD) $(CPPFLAGS) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(REP_GTK_LIBS)
+
+ %-glue.c : %.defs build-gtk.jlc
+- rep build-gtk.jlc -f build-gtk-batch $< $@
++ LC_ALL=C rep build-gtk.jlc -f build-gtk-batch $< $@
+
+ build-gtk.jlc : build-gtk.jl
+ rep compiler -f compile-batch $<
diff --git a/x11-libs/rep-gtk/rep-gtk-0.18.4.ebuild b/x11-libs/rep-gtk/rep-gtk-0.18.4.ebuild
new file mode 100644
index 000000000000..5f36d5a10a5e
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.18.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18.4.ebuild,v 1.1 2009/03/08 20:06:34 truedfx Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rep-gtk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/librep-0.17.3
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-libdir.patch
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS BUGS ChangeLog HACKING README* TODO
+}