summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-14 11:24:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-14 11:24:25 +0000
commite2175da254e98665ed15e29891fac10f54292af1 (patch)
treed753b12da1ac768915b01543917bb55778cbbc21 /x11-libs/qwtplot3d-qt3
parentmove messages out of src_unpack and into pkg_setup and drop dead $myconf usag... (diff)
downloadgentoo-2-e2175da254e98665ed15e29891fac10f54292af1.tar.gz
gentoo-2-e2175da254e98665ed15e29891fac10f54292af1.tar.bz2
gentoo-2-e2175da254e98665ed15e29891fac10f54292af1.zip
Fixed qt4->qt3 need for opengl use flag
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'x11-libs/qwtplot3d-qt3')
-rw-r--r--x11-libs/qwtplot3d-qt3/ChangeLog8
-rw-r--r--x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild24
2 files changed, 21 insertions, 11 deletions
diff --git a/x11-libs/qwtplot3d-qt3/ChangeLog b/x11-libs/qwtplot3d-qt3/ChangeLog
index 84e475271dc5..b5acaf630b8c 100644
--- a/x11-libs/qwtplot3d-qt3/ChangeLog
+++ b/x11-libs/qwtplot3d-qt3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qwtplot3d-qt3
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d-qt3/ChangeLog,v 1.2 2007/12/03 10:17:10 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d-qt3/ChangeLog,v 1.3 2008/01/14 11:24:25 bicatali Exp $
+
+ 14 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ qwtplot3d-qt3-0.2.7.ebuild:
+ Fixed qt4->qt3 need for opengl use flag
03 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org>
qwtplot3d-qt3-0.2.7.ebuild:
diff --git a/x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild b/x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild
index 51050a4b03e3..495a5f56c0b3 100644
--- a/x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild
+++ b/x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild,v 1.2 2007/12/03 10:17:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d-qt3/qwtplot3d-qt3-0.2.7.ebuild,v 1.3 2008/01/14 11:24:25 bicatali Exp $
inherit eutils multilib qt3
@@ -19,10 +19,15 @@ RDEPEND="$(qt_min_version 3.3)"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-QT4_BUILT_WITH_USE_CHECK="opengl"
-
S="${WORKDIR}/${MY_PN}"
+pkg_setup() {
+ if ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
src_unpack () {
unpack ${A}
epatch "${FILESDIR}"/${MY_PN}-profile.patch
@@ -32,11 +37,12 @@ src_unpack () {
}
src_compile () {
- echo >> ${MY_PN}.pro "target.path = /usr/$(get_libdir)"
- echo >> ${MY_PN}.pro "headers.path = /usr/include/${PN}"
- echo >> ${MY_PN}.pro "headers.files = \$\$HEADERS"
- echo >> ${MY_PN}.pro "INSTALLS = target headers"
-
+ cat >> ${MY_PN}.pro <<-EOF
+ target.path = /usr/$(get_libdir)
+ headers.path = /usr/include/${PN}
+ headers.files = \$\$HEADERS
+ INSTALLS = target headers
+ EOF
eqmake3 ${MY_PN}.pro || die "eqmake3 failed"
emake || die "emake failed"
if use doc; then