summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-09 15:48:31 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-09 15:48:31 +0000
commit77d2cd903a0d279029a9561f1be911cbda2d2846 (patch)
tree52e52721379d7fd4a9459957e54ee6013e1f8c1d /x11-libs/qt-opengl
parentversion bump (diff)
downloadgentoo-2-77d2cd903a0d279029a9561f1be911cbda2d2846.tar.gz
gentoo-2-77d2cd903a0d279029a9561f1be911cbda2d2846.tar.bz2
gentoo-2-77d2cd903a0d279029a9561f1be911cbda2d2846.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/ChangeLog7
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.7.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 32c1e6b5ab01..5fe42652a878 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.80 2010/11/06 09:36:08 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.81 2010/11/09 15:48:31 wired Exp $
+
+*qt-opengl-4.7.1 (09 Nov 2010)
+
+ 09 Nov 2010; Alex Alexander <wired@gentoo.org> +qt-opengl-4.7.1.ebuild:
+ version bump
06 Nov 2010; Alex Alexander <wired@gentoo.org> qt-opengl-4.7.0.ebuild,
qt-opengl-4.7.0-r1.ebuild:
diff --git a/x11-libs/qt-opengl/qt-opengl-4.7.1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.7.1.ebuild
new file mode 100644
index 000000000000..f162945f68ad
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.7.1.ebuild,v 1.1 2010/11/09 15:48:31 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="egl qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=,egl=,qt3support=]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/opengl
+ src/plugins/graphicssystems/opengl"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenGL
+ src/corelib
+ src/gui
+ src/opengl
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="opengl"
+ QCONFIG_DEFINE="QT_OPENGL $(use egl && echo QT_EGL)"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)
+ $(qt_use egl)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}