summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-10 17:42:42 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-03-10 17:42:42 +0000
commit4d8c192caf36389c30c1dcf4f112d9b076a563ed (patch)
treee68c39c56526ceb9b90aa61f9c597225b2f6cc10 /x11-libs/qscintilla
parentSet KV_min for 9999 to 2.6.39 because we don't patch live version. (diff)
downloadgentoo-2-4d8c192caf36389c30c1dcf4f112d9b076a563ed.tar.gz
gentoo-2-4d8c192caf36389c30c1dcf4f112d9b076a563ed.tar.bz2
gentoo-2-4d8c192caf36389c30c1dcf4f112d9b076a563ed.zip
Version bump wrt bug #460934.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/ChangeLog8
-rw-r--r--x11-libs/qscintilla/qscintilla-2.7.1.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/x11-libs/qscintilla/ChangeLog b/x11-libs/qscintilla/ChangeLog
index 42b74681e854..d590aeb4162c 100644
--- a/x11-libs/qscintilla/ChangeLog
+++ b/x11-libs/qscintilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qscintilla
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.83 2013/03/02 23:45:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.84 2013/03/10 17:42:42 kensington Exp $
+
+*qscintilla-2.7.1 (10 Mar 2013)
+
+ 10 Mar 2013; Michael Palimaka <kensington@gentoo.org>
+ +qscintilla-2.7.1.ebuild:
+ Version bump wrt bug #460934.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> qscintilla-2.6.2.ebuild,
qscintilla-2.7.ebuild:
diff --git a/x11-libs/qscintilla/qscintilla-2.7.1.ebuild b/x11-libs/qscintilla/qscintilla-2.7.1.ebuild
new file mode 100644
index 000000000000..02f00e9d6e66
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.7.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.7.1.ebuild,v 1.1 2013/03/10 17:42:42 kensington Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+MY_P=QScintilla-gpl-${PV}
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0/9"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ qt4-r2_src_unpack
+
+ # Sub-slot sanity check
+ local subslot=${SLOT#*/}
+ local version=$(sed -nre 's:.*VERSION\s*=\s*([0-9\.]+):\1:p' "${S}"/Qt4Qt5/qscintilla.pro)
+ local major=${version%%.*}
+ if [[ ${subslot} != ${major} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${subslot}) does not match QScintilla major version (${major})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${major}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+}
+
+src_configure() {
+ pushd Qt4Qt5 > /dev/null
+ einfo "Configuration of qscintilla"
+ eqmake4 qscintilla.pro
+ popd > /dev/null
+
+ pushd designer-Qt4Qt5 > /dev/null
+ einfo "Configuration of designer plugin"
+ eqmake4 designer.pro
+ popd > /dev/null
+}
+
+src_compile() {
+ pushd Qt4Qt5 > /dev/null
+ einfo "Building of qscintilla"
+ emake
+ popd > /dev/null
+
+ pushd designer-Qt4Qt5 > /dev/null
+ einfo "Building of designer plugin"
+ emake
+ popd > /dev/null
+}
+
+src_install() {
+ pushd Qt4Qt5 > /dev/null
+ einfo "Installation of qscintilla"
+ emake INSTALL_ROOT="${D}" install
+ popd > /dev/null
+
+ pushd designer-Qt4Qt5 > /dev/null
+ einfo "Installation of designer plugin"
+ emake INSTALL_ROOT="${D}" install
+ popd > /dev/null
+
+ dodoc NEWS
+
+ if use doc; then
+ dohtml doc/html-Qt4Qt5/*
+ insinto /usr/share/doc/${PF}
+ doins -r doc/Scintilla
+ fi
+}