summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-02-12 14:43:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-02-12 14:43:45 +0000
commitacccaa0e0f348cee0add2c543442ba9cfcfdfb6c (patch)
tree22dae05fc67515d02be5f0a48219cc31373f97e6 /x11-libs/mx
parentalpha/ia64/sparc stable wrt #399309 (diff)
downloadgentoo-2-acccaa0e0f348cee0add2c543442ba9cfcfdfb6c.tar.gz
gentoo-2-acccaa0e0f348cee0add2c543442ba9cfcfdfb6c.tar.bz2
gentoo-2-acccaa0e0f348cee0add2c543442ba9cfcfdfb6c.zip
Version bump, bug #403097, thanks to David.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-libs/mx')
-rw-r--r--x11-libs/mx/ChangeLog9
-rw-r--r--x11-libs/mx/mx-1.4.2.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/x11-libs/mx/ChangeLog b/x11-libs/mx/ChangeLog
index 99c0e8a7fbff..6148666e6f76 100644
--- a/x11-libs/mx/ChangeLog
+++ b/x11-libs/mx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/mx
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/mx/ChangeLog,v 1.2 2011/09/15 22:10:39 eva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/mx/ChangeLog,v 1.3 2012/02/12 14:43:45 eva Exp $
+
+*mx-1.4.2 (12 Feb 2012)
+
+ 12 Feb 2012; Gilles Dartiguelongue <eva@gentoo.org> +mx-1.4.2.ebuild:
+ Version bump, bug #403097, thanks to David.
*mx-1.3.1 (15 Sep 2011)
*mx-1.2.1 (15 Sep 2011)
diff --git a/x11-libs/mx/mx-1.4.2.ebuild b/x11-libs/mx/mx-1.4.2.ebuild
new file mode 100644
index 000000000000..bbf6ca722e89
--- /dev/null
+++ b/x11-libs/mx/mx-1.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/mx/mx-1.4.2.ebuild,v 1.1 2012/02/12 14:43:45 eva Exp $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+
+inherit clutter
+
+DESCRIPTION="A widget toolkit using Clutter"
+HOMEPAGE="http://clutter-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug doc glade +gtk +introspection startup-notification"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=media-libs/clutter-1.7.91:1.0
+ >=x11-apps/xrandr-1.2.0
+
+ x11-libs/gdk-pixbuf:2[introspection?]
+
+ dbus? ( >=dev-libs/dbus-glib-0.82 )
+ glade? (
+ >=dev-util/glade-3.4.5:3
+ <dev-util/glade-3.9.1:3 )
+ gtk? ( >=x11-libs/gtk+-2.20:2[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ startup-notification? ( >=x11-libs/startup-notification-0.9 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+
+DOCS="ChangeLog NEWS README"
+
+src_prepare() {
+ # Tests are interactive, no use for us
+ sed -e 's/^\(SUBDIRS .*\)tests\(.*\)/\1 \2/g' \
+ -i Makefile.am -i Makefile.in || die
+}
+
+src_configure() {
+ local myconf
+
+ myconf="--enable-maintainer-flags=no
+ --with-winsys=x11
+ $(use_enable gtk gtk-widgets)
+ $(use_enable introspection)
+ $(use_with dbus)
+ $(use_with glade)
+ $(use_with startup-notification)"
+
+ econf ${myconf}
+}